summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2021-04-12 22:44:52 -0700
committerMaximilian Weiss2021-04-12 22:44:52 -0700
commit91f988635f40387569196e278b336eea3c01d73f (patch)
tree0091f795794181af9ed3e67aca97267688e6bbfb
parente99165d0db517420617d23a6ab5c97ff2e567a16 (diff)
downloadaur-91f988635f40387569196e278b336eea3c01d73f.tar.gz
Update to v0.1.32 and fix version detection
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4ec3a8f9bcd..e5dfdc699a93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-btchip-git
pkgdesc = Python library to communicate with BTChip dongle
- pkgver = 0.1.31
- pkgrel = 2
+ pkgver = 0.1.32
+ pkgrel = 1
url = https://github.com/LedgerHQ/btchip-python
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 51e5044e625c..2d1fc6118bcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python-btchip-git
-pkgver=0.1.31
-pkgrel=2
+pkgver=0.1.32
+pkgrel=1
pkgdesc="Python library to communicate with BTChip dongle"
arch=('any')
depends=('python-hidapi' 'libusb-compat' 'libusb' 'libsystemd')
@@ -19,12 +19,12 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/btchip-python/"
- git tag -l | tail -n 1 | sed 's/v//g'
+ git tag -l | sed 's/v//g' | sort | tail -n 1
}
build() {
cd "$srcdir/btchip-python/"
- git checkout $(git tag -l | tail -n 1) > /dev/null 2>&1
+ git checkout $(git tag -l | sed 's/v//g' | sort | tail -n 1) > /dev/null 2>&1
python setup.py build
}