summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikuro Kagamine2020-06-12 00:18:48 +1000
committerMikuro Kagamine2020-06-12 00:18:48 +1000
commit926600e7f074fe342ae6f33d7331b7f1ec72cb31 (patch)
tree222a1cd0f9a9dad690d8f35bc26c30a0733e6493
parent6f626ca9cdc8bb02fecac73be8365b3ba958e151 (diff)
downloadaur-926600e7f074fe342ae6f33d7331b7f1ec72cb31.tar.gz
Move firefox dependency into package function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43fdb4281a43..d3e42cab41cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = browsh
pkgdesc = A fully-modern text-based browser, rendering to TTY and browsers
pkgver = 1.6.4
- pkgrel = 1
+ pkgrel = 2
url = https://www.brow.sh
arch = x86_64
arch = i686
@@ -14,7 +14,6 @@ pkgbase = browsh
makedepends = go-bindata
makedepends = dep
makedepends = git
- depends = firefox>=63
optdepends = upx: compress binary
conflicts = browsh-bin
conflicts = browsh-git
@@ -26,4 +25,5 @@ pkgbase = browsh
sha256sums = b410527a69dba88a30d8a6d341a20eb5cb1f84b684e9bc8bb6bc88a2930e0eea
pkgname = browsh
+ depends = firefox>=63
diff --git a/PKGBUILD b/PKGBUILD
index 928de35f39be..3925a063d5a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,11 @@
pkgname=browsh
pkgver=1.6.4
-pkgrel=1
+pkgrel=2
pkgdesc='A fully-modern text-based browser, rendering to TTY and browsers'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='https://www.brow.sh'
license=('LGPL2.1')
-depends=('firefox>=63')
makedepends=('go' 'go-bindata' 'dep' 'git')
optdepends=('upx: compress binary')
conflicts=('browsh-bin' 'browsh-git')
@@ -61,5 +60,6 @@ build() {
}
package() {
+ depends=('firefox>=63')
install -Dm755 $pkgname "${pkgdir}/usr/bin/${pkgname}"
}