summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKamran Mackey2015-12-08 04:33:14 -0700
committerKamran Mackey2015-12-08 04:33:14 -0700
commit9362659a7a8389b181f0947435d498fecefd36d6 (patch)
treec15aa9a08d9cae5acc84668b8de593f1c11febe8
parent919d564cf9a58ef128832c93fdff36bd029f8306 (diff)
downloadaur-9362659a7a8389b181f0947435d498fecefd36d6.tar.gz
Reverted the past 3 commits. but kept the .install file.
-rw-r--r--PKGBUILD8
-rw-r--r--git-daemon.socket10
-rw-r--r--git-daemon@.service10
3 files changed, 1 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ad59a127344..ea746721b6bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,7 @@ conflicts=('git')
provides=('git')
install=git-git.install
source=(git://github.com/git/git.git)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP')
+md5sums=('SKIP')
_gitname=git
pkgver() {
@@ -44,8 +42,4 @@ build() {
package() {
cd "$_gitname"
make DESTDIR="$pkgdir" install install-doc
-
- # git-daemon via systemd socket activation
- install -D -m 644 "$srcdir"/git-daemon@.service "$pkgdir"/usr/lib/systemd/system/git-daemon@.service
- install -D -m 644 "$srcdir"/git-daemon.socket "$pkgdir"/usr/lib/systemd/system/git-daemon.socket
}
diff --git a/git-daemon.socket b/git-daemon.socket
deleted file mode 100644
index dd19082c9c45..000000000000
--- a/git-daemon.socket
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Git Daemon Socket
-
-[Socket]
-ListenStream=9418
-Accept=true
-
-[Install]
-WantedBy=sockets.target
-
diff --git a/git-daemon@.service b/git-daemon@.service
deleted file mode 100644
index 55ca7141b31a..000000000000
--- a/git-daemon@.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Git Daemon Instance
-
-[Service]
-User=git
-# The '-' is to ignore non-zero exit statuses
-ExecStart=-/usr/lib/git-core/git-daemon --inetd --export-all --base-path=/srv/git
-StandardInput=socket
-StandardOutput=inherit
-StandardError=journal