summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2023-02-13 21:56:49 +1100
committerLuis Aranguren2023-02-13 21:56:49 +1100
commit93ec370595688a0bff3761a8b4b999af05076081 (patch)
treed52b574aa15d079b99e27ba75c14b2407830fa85
parent6947358778bc5d4d317dfba864d6ad1ef5a3da03 (diff)
downloadaur-93ec370595688a0bff3761a8b4b999af05076081.tar.gz
updated pkgver 4.3.2.r576.g292ce3594, included electrum-locale submodule
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4639d3302df7..adffc361779e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = electrum-git
pkgdesc = Lightweight Bitcoin wallet
- pkgver = 4.3.2.r226.g4784d933f
+ pkgver = 4.3.2.r576.g292ce3594
pkgrel = 1
url = https://github.com/spesmilo/electrum
install = electrum.install
@@ -51,6 +51,8 @@ pkgbase = electrum-git
provides = electrum
conflicts = electrum
source = git+https://github.com/spesmilo/electrum
+ source = git+https://github.com/spesmilo/electrum-locale
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = electrum-git
diff --git a/PKGBUILD b/PKGBUILD
index 1be1096e4aa7..d7f8d6d71b78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Marcel O'Neil <marcel@marceloneil.com>
pkgname=electrum-git
-pkgver=4.3.2.r226.g4784d933f
+pkgver=4.3.2.r576.g292ce3594
pkgrel=1
pkgdesc="Lightweight Bitcoin wallet"
arch=('any')
@@ -54,23 +54,26 @@ optdepends=('desktop-file-utils: update desktop icon'
'xdg-utils: update desktop icon'
'python-amodem: air-gapped transaction signing over audio modem'
'zbar: QR code reading support')
-source=(git+https://github.com/spesmilo/electrum)
-sha256sums=('SKIP')
+source=(git+https://github.com/spesmilo/electrum
+ git+https://github.com/spesmilo/electrum-locale)
+sha256sums=('SKIP'
+ 'SKIP')
provides=('electrum')
conflicts=('electrum')
install=electrum.install
pkgver() {
cd ${pkgname%-git}
-# git log -1 --format="%cd" --date=short --no-show-signature | sed "s|-||g"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd ${pkgname%-git}
echo 'Initializing git submodule...'
git submodule init
+ git config submodule.contrib/deterministic-build/electrum-locale.url "$srcdir/electrum-locale"
+ git -c protocol.file.allow=always submodule update
echo 'Compiling protobuf description file...'
protoc \
@@ -80,7 +83,10 @@ build() {
echo 'Creating translations...'
python contrib/pull_locale
+}
+build() {
+ cd ${pkgname%-git}
echo 'Building...'
python setup.py build
}