summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2015-10-05 18:27:09 +0200
committerQuan Guo2015-10-05 18:27:09 +0200
commit94e393ad60375afffa6f20b43279c5b61bf716eb (patch)
tree71393aaf62d1c5f6f89aeb2f0f58c6645f9ca51a
downloadaur-94e393ad60375afffa6f20b43279c5b61bf716eb.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f47592a88835
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fpp-git
+ pkgdesc = Facebook PathPicker is a simple command line tool that solves the perpetual problem of selecting files out of bash output.
+ pkgver = 0.6.2r.403
+ pkgrel = 1
+ url = https://github.com/facebook/PathPicker
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python2
+ depends = ruby
+ provides = fpp
+ conflicts = fpp
+ source = git+https://github.com/facebook/PathPicker.git
+ sha256sums = SKIP
+
+pkgname = fpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07a0232dce6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lucas Sampaio <lucas@lsmagalhaes.com>
+# Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=fpp-git
+pkgver=0.6.2r.403
+pkgrel=1
+pkgdesc='Facebook PathPicker is a simple command line tool that solves the perpetual problem of selecting files out of bash output.'
+url='https://github.com/facebook/PathPicker'
+license=('BSD')
+source=('git+https://github.com/facebook/PathPicker.git')
+sha256sums=('SKIP')
+arch=('any')
+makedepends=('git' 'python2')
+depends=('ruby')
+conflicts=('fpp')
+provides=('fpp')
+
+pkgver() {
+ cd "${srcdir}/PathPicker"
+ printf "%sr.%s" "$(git describe --abbrev=0 --tags)" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ mkdir -p $pkgdir/opt/PathPicker
+ cp -r $srcdir/PathPicker $pkgdir/opt
+
+ mkdir -p $pkgdir/usr/bin
+ ln -s "/opt/PathPicker/fpp" "$pkgdir/usr/bin/fpp"
+}