summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2022-06-20 11:46:15 -0400
committerPhilip Sequeira2022-06-20 11:46:15 -0400
commit95b81dc746448a815b8b7912f6a47796d639dd0c (patch)
tree3334a18426360f8f0f766e21fd73a047791db459
parent623dbe9750122338cecc7f6fbb8fac088ff40a27 (diff)
downloadaur-95b81dc746448a815b8b7912f6a47796d639dd0c.tar.gz
warning message on upgrade if x11 likely disabled by missing depend
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--mpv.install28
3 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82c249283901..9572ea31ff83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.34.0_345_g44ecf83a1b
+ pkgver = 0.34.0_351_g45ff20986d
pkgrel = 1
url = https://mpv.io
install = mpv.install
diff --git a/PKGBUILD b/PKGBUILD
index d6c386655f76..308fec9cf4de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Philip Sequeira <phsequei@gmail.com>
+# Maintainer: Philip Sequeira <qmega@mailbox.org>
# Contributor: Rudolf Polzer <divVerent@xonotic.org>
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: Eivind Uggedal <eivind@uggedal.com>
@@ -47,7 +47,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.34.0_345_g44ecf83a1b
+pkgver=0.34.0_351_g45ff20986d
pkgrel=1
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
diff --git a/mpv.install b/mpv.install
index bdbd170ceb6a..8ebd029c4f57 100644
--- a/mpv.install
+++ b/mpv.install
@@ -1,13 +1,25 @@
pre_install() {
cat <<'EOF'
NOTE: mpv has several optional features that are automatically enabled if the
-required libraries are present at configure time. This package does not include
-any of the optional features as dependencies by default (but it does add depends
-for whatever is linked against when building the package). If you want to use
-any optional features that require libraries you don't currently have installed,
-please install the relevant libraries and rebuild the package. A frequently
-desired optional feature is Lua support, which is necessary for the on-screen
-controller "GUI", youtube-dl integration, and other extension scripts. Lua
-support can be provided by lua52 or luajit.
+ required libraries are present at configure time. This package does not
+ include any of the optional features as dependencies by default (but it
+ does add depends for whatever is linked against when building the
+ package). If you want to use any optional features that require libraries
+ you don't currently have installed, please install those libraries and
+ rebuild the package. A frequently desired optional feature is Lua support,
+ which is necessary for the on-screen controller "GUI", youtube-dl
+ integration, and other extension scripts. Lua support can be provided by
+ lua52 or luajit. Some common features are listed in _opt_features near the
+ top of the PKGBUILD; uncomment to add the relevant dependencies.
EOF
}
+
+pre_upgrade() {
+ if (( $(vercmp $2 0.34.0_348_g3d459832a8) < 0 )) && pacman --deptest libxinerama libxrandr libxss >/dev/null && ! pacman --deptest libxpresent >/dev/null; then
+ cat <<'EOF'
+WARNING: You likely had X11 support enabled for mpv, but it is not enabled in
+ this build because new dependency libxpresent is not installed. If you
+ need X11 support, please install libxpresent and rebuild mpv-git.
+EOF
+ fi
+}