summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2023-07-24 23:35:17 +0200
committerUffe Jakobsen2023-07-24 23:35:17 +0200
commit965e7c7a22dbe754957e25de968d66807c6adccf (patch)
treeaf94100df47e37435525b06a76529ad1cfdafc6a
parent1b83d60fa7ecc8ede49f157f694a928e1de03ab0 (diff)
downloadaur-965e7c7a22dbe754957e25de968d66807c6adccf.tar.gz
Clean up
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD54
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bbe941732bd..3beb48c1d081 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = codelite-git
pkgdesc = Cross platform IDE for C, C++, Rust, Python, PHP and Node.js written in C++
pkgver = 17.4.0.r23.gcbbda264d
pkgrel = 1
- url = http://www.codelite.org/
+ url = https://www.codelite.org/
arch = i686
arch = x86_64
arch = aarch64
@@ -12,7 +12,7 @@ pkgbase = codelite-git
makedepends = ninja
makedepends = clang
makedepends = git
- depends = wxgtk3
+ depends = wxwidgets-gtk3
depends = libedit
depends = libssh
depends = mariadb-libs
diff --git a/PKGBUILD b/PKGBUILD
index 402715b43c51..a592c7a3365e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,50 +17,50 @@ pkgver=17.4.0.r23.gcbbda264d
pkgrel=1
pkgdesc="Cross platform IDE for C, C++, Rust, Python, PHP and Node.js written in C++"
arch=('i686' 'x86_64' 'aarch64')
-url="http://www.codelite.org/"
+url="https://www.codelite.org/"
license=('GPL')
makedepends=('pkgconfig' 'cmake' 'ninja' 'clang' 'git')
depends=(
- 'wxgtk3'
- 'libedit'
- 'libssh'
- 'mariadb-libs'
- 'ncurses'
- 'uchardet'
- 'hunspell'
- #'ctags'
- #'xterm'
- #'wget'
- #'curl'
- #'python'
- #'python2'
+ 'wxwidgets-gtk3'
+ 'libedit'
+ 'libssh'
+ 'mariadb-libs'
+ 'ncurses'
+ 'uchardet'
+ 'hunspell'
+ #'ctags'
+ #'xterm'
+ #'wget'
+ #'curl'
+ #'python'
+ #'python2'
)
optdepends=(
- 'clang: compiler'
- 'lldb: debugger'
- 'gcc: compiler'
- 'gdb: debugger'
- 'valgrind: debugger'
- 'rust: language'
- 'php: language'
- 'graphviz: callgraph visualization'
- 'cscope: CScope Integration for CodeLite'
+ 'clang: compiler'
+ 'lldb: debugger'
+ 'gcc: compiler'
+ 'gdb: debugger'
+ 'valgrind: debugger'
+ 'rust: language'
+ 'php: language'
+ 'graphviz: callgraph visualization'
+ 'cscope: CScope Integration for CodeLite'
)
conflicts=('codelite' 'codelite-bin')
provides=('codelite')
source=(
- ${_gitname}::git+https://github.com/eranif/codelite.git
- http://repos.codelite.org/wxCrafterLibs/wxgui.zip
+ ${_gitname}::git+https://github.com/eranif/codelite.git
+ http://repos.codelite.org/wxCrafterLibs/wxgui.zip
)
sha256sums=(
- 'SKIP'
- 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
noextract=('wxgui.zip')