summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-05-21 07:30:06 +0200
committerwillemw122023-05-21 07:30:06 +0200
commit969af3963003ac941694fdbc74c5549b4dbc5053 (patch)
treeb1bb9868d633e3a3dfb20907565157a7fd2ae79e
parentea5241eb5233aa7002116d30169835a09dcbca8f (diff)
downloadaur-969af3963003ac941694fdbc74c5549b4dbc5053.tar.gz
Workaround gcc compile error
Minor edits.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--sickchill.service1
-rw-r--r--sickchill.sysusers1
4 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d86017fe457..e22fce369491 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,8 +16,8 @@ pkgbase = sickchill-git
source = sickchill.service
source = sickchill.sysusers
source = sickchill.tmpfiles
- sha256sums = a7bb9f2406721f9d5eb66dab954bfc54f6bfe74fa6efd646e1006903e3e42bc8
- sha256sums = 1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850
+ sha256sums = b417284472d804e634c0dcaac2876ca164ad9a485f947e0f05798d0ce1136d59
+ sha256sums = aaeb298c9717da8b28853ed15509fb8428d975ae49e8737ebcec15caab9f0978
sha256sums = 2069f15e18fc7dd0f0f25b623f2067fc9028b1ca4122021a62364aa39914f88f
pkgname = sickchill-git
diff --git a/PKGBUILD b/PKGBUILD
index 8edb43929335..c3f4d6800c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# That is the only reason why this package ends on -git.
pkgname=sickchill-git
-pkgver=2022.7.20.r0
+pkgver=2023.1.2.r0
pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
@@ -17,15 +17,15 @@ license=('GPL3')
makedepends=('jq' 'python-virtualenv')
optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
'unrar: for RAR files')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
options=('!strip')
install=$pkgname.install
source=('sickchill.service'
'sickchill.sysusers'
'sickchill.tmpfiles')
-sha256sums=('a7bb9f2406721f9d5eb66dab954bfc54f6bfe74fa6efd646e1006903e3e42bc8'
- '1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850'
+sha256sums=('b417284472d804e634c0dcaac2876ca164ad9a485f947e0f05798d0ce1136d59'
+ 'aaeb298c9717da8b28853ed15509fb8428d975ae49e8737ebcec15caab9f0978'
'2069f15e18fc7dd0f0f25b623f2067fc9028b1ca4122021a62364aa39914f88f')
pkgver() {
@@ -35,6 +35,8 @@ pkgver() {
}
build() {
+ export CFLAGS="$CFLAGS -Wno-deprecated-declarations"
+
#python -m venv build
export XDG_CACHE_HOME=cache/pip
VIRTUALENV_OVERRIDE_APP_DATA=cache/virtualenv virtualenv build
@@ -54,4 +56,3 @@ package() {
install -dm755 "$pkgdir/opt/sickchill"
cp -a build "$pkgdir/opt/sickchill/app"
}
-
diff --git a/sickchill.service b/sickchill.service
index 8962fbc44511..fb4dec3dca42 100644
--- a/sickchill.service
+++ b/sickchill.service
@@ -8,6 +8,7 @@ User=sickchill
Group=sickchill
Type=simple
+#ExecStart=/var/lib/sickchill/app/bin/SickChill --quiet --nolaunch --datadir=/var/lib/sickchill/data
ExecStart=/opt/sickchill/app/bin/SickChill --quiet --nolaunch --datadir=/opt/sickchill/data
[Install]
diff --git a/sickchill.sysusers b/sickchill.sysusers
index e535bb2be54f..cb39976db281 100644
--- a/sickchill.sysusers
+++ b/sickchill.sysusers
@@ -1 +1,2 @@
+#u sickchill - "SickChill Daemon" /var/lib/sickchill
u sickchill - "SickChill Daemon" /opt/sickchill