summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-05-26 16:44:00 +0200
committerbartus2019-05-26 16:44:00 +0200
commit96ec8a3fcbe2a4f2696fee85cb4f80d950922caf (patch)
tree48956c03f20356bfe26e828c96f1e91561dd8287
parent07a222e28caefbf60c1be91f18011dd8cb2c3a6a (diff)
downloadaur-96ec8a3fcbe2a4f2696fee85cb4f80d950922caf.tar.gz
add `disjoint-set datastructure` of `mapmap_cpu`
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cb317c10b48..32d3faf682b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mve-git
pkgdesc = Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,
- pkgver = r1263.201dc4b
+ pkgver = r1274.45a911b
pkgrel = 1
url = http://www.gcc.tu-darmstadt.de/home/proj/mve/
arch = i686
@@ -21,11 +21,13 @@ pkgbase = mve-git
source = mve-git-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git
source = git+https://github.com/nmoehrle/mvs-texturing.git
source = git+https://github.com/flanggut/smvs.git
+ source = https://github.com/nmoehrle/mvs-texturing/pull/119.patch
source = gtest.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 81bb7655edc225a4188d63b0b063eb32
md5sums = 7098c8ebc8ba0c461b81d210a9057118
pkgname = mve-git
diff --git a/PKGBUILD b/PKGBUILD
index 38368814bc18..382a178464d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=mve-git
-pkgver=r1263.201dc4b
+pkgver=r1274.45a911b
pkgrel=1
pkgdesc="Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,"
arch=('i686' 'x86_64')
@@ -15,12 +15,14 @@ source=("${pkgname}::git+https://github.com/simonfuhrmann/mve.git"
"${pkgname}-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git"
"git+https://github.com/nmoehrle/mvs-texturing.git"
"git+https://github.com/flanggut/smvs.git"
+ "https://github.com/nmoehrle/mvs-texturing/pull/119.patch"
'gtest.patch'
)
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ '81bb7655edc225a4188d63b0b063eb32'
'7098c8ebc8ba0c461b81d210a9057118')
_binar="apps/sfmrecon/sfmrecon
apps/meshconvert/meshconvert
@@ -38,8 +40,10 @@ apps/sceneupgrade/sceneupgrade"
prepare() {
cd ${srcdir}
patch -Np1 -i gtest.patch
- cd ${pkgname}
+ cd ${srcdir}/${pkgname}
sed -i '/CXXFLAGS*/s/$/ -msse4.2/' libs/sfm/Makefile
+ cd ${srcdir}/mvs-texturing
+ git apply -v ${srcdir}/119.patch
}
pkgver() {