summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRustmilian2023-03-18 17:17:05 -0400
committerCaleb Maclennan2023-03-19 12:05:31 +0300
commit97b82e4c590cacfede9c7571dd038c0ea7d90a19 (patch)
tree998b899cbb1ab91fc7b4e84820ce547d9004f234
parent85126ea9ab5fe7b9fc21a15bf2b1f62ee259fbe8 (diff)
downloadaur-97b82e4c590cacfede9c7571dd038c0ea7d90a19.tar.gz
Handle depot-tools-git TODOs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b7f40d30219..e15dd462702a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = depot-tools-git
pkgdesc = Tools for working with Chromium development
- pkgver = r9431.c5b38329e
+ pkgver = r9435.249e9a26c
pkgrel = 1
url = https://chromium.googlesource.com/chromium/tools/depot_tools
install = depot-tools-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 9fb355e25cec..c42a70e5e976 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,10 @@
# Contributor: Andreas Schrafl <aschrafl@gmail.com>
# Contributor: piojo <aur@zwell.net>
# Contributor: hack.augusto <hack.augusto@gmail.com>
+# Contributor: Rustmilian <Rustmilian@proton.me>
pkgname=depot-tools-git
-pkgver=r9431.c5b38329e
+pkgver=r9435.249e9a26c
pkgrel=1
pkgdesc='Tools for working with Chromium development'
arch=(x86_64)
@@ -31,24 +32,12 @@ package() {
install -d "$pkgdir/opt/"
cp -r "$srcdir/depot_tools/" "$pkgdir/opt/depot_tools/"
chmod 775 "$pkgdir/opt/depot_tools/"
-
- rm -rf "$pkgdir/opt/depot_tools/.git/"
-
- # Make Windows files non-executable
- chmod a-x "$pkgdir/opt/depot_tools/"*.bat
-
- # TODO: Consider removing unneeded files, for example:
- # .git{ignore,attributes}
- # *OWNERS
- # WATCHLISTS
- # bootstrap/
- # infra/
- # ninja-{mac,linux32}
- # *.bat
- # testing_support/
- # tests/
- # win32imports.py
- # win_toolchain/
+ # Remove Git
+ rm -rf "${pkgdir}/opt/depot_tools/"{.git,.gitignore,.gitattributes}
+ # Remove Windows
+ rm -r "${pkgdir}/opt/depot_tools/"{*.bat,win32imports.py,win_toolchain}
+ # Remove Misc
+ rm -r "${pkgdir}/opt/depot_tools/"{bootstrap,infra,testing_support,tests,OWNERS,WATCHLISTS}
# Install license
install -d "$pkgdir/usr/share/licenses/$pkgname/"
@@ -71,5 +60,6 @@ package() {
mv "$pkgdir/opt/depot_tools/gclient_completion.sh" "$pkgdir/usr/share/bash-completion/completions/gclient"
mv "$pkgdir/opt/depot_tools/git_cl_completion.sh" "$pkgdir/usr/share/bash-completion/completions/git-cl"
- # TODO: Install zsh-goodies/?
+ # Install zsh completions
+ install -Dm0644 -t "$pkgdir/usr/share/zsh/site-functions/" "$pkgdir/opt/depot_tools/zsh-goodies/_gclient"
}