summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-06-10 10:58:12 +0100
committerCharles Bos2015-06-10 10:58:12 +0100
commit97baaf9b6d26548ff653fe82edc3486f232baecb (patch)
tree4319e0bc9b4dbf0250420b0831bd4d83a1e40ea7
downloadaur-97baaf9b6d26548ff653fe82edc3486f232baecb.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7ea103c2b6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Fri Jun 5 07:16:00 UTC 2015
+pkgbase = xfce4-places-plugin
+ pkgdesc = Places menu plugin for the Xfce panel
+ pkgver = 1.7.0
+ pkgrel = 2
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ depends = libnotify
+ depends = xfce4-panel
+ source = http://archive.xfce.org/src/panel-plugins/xfce4-places-plugin/1.7/xfce4-places-plugin-1.7.0.tar.bz2
+ sha256sums = 4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
+
+pkgname = xfce4-places-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bfba4d0135e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alessio Sergi <asergi at archlinux dot us>
+pkgname=xfce4-places-plugin
+pkgver=1.7.0
+pkgrel=2
+pkgdesc="Places menu plugin for the Xfce panel"
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
+license=('GPL2')
+depends=('libnotify' 'xfce4-panel')
+makedepends=('intltool')
+source=("http://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.bz2")
+sha256sums=('4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ # add compatibility for inline functions
+ CFLAGS=-fgnu89-inline ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}