summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2017-11-25 15:42:10 +0100
committerPhilipp Wolfer2017-11-25 15:42:10 +0100
commit996a71bc7a241c424612fe4c21add3c3e556bed5 (patch)
tree22ff1bb4d4c615465bc64cab4cabf8c3a1b10c2c
parentd73f1fc978a939164984f876c8ec1aab7f2bbd3f (diff)
downloadaur-996a71bc7a241c424612fe4c21add3c3e556bed5.tar.gz
New upstream release 1.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea7aa420cfb5..a27cc08c43d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Nov 5 13:08:43 UTC 2017
+# Sat Nov 25 14:42:10 UTC 2017
pkgbase = peek
pkgdesc = Simple screen recorder with an easy to use interface
- pkgver = 1.1.0
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
url = https://github.com/phw/peek
arch = i686
arch = x86_64
@@ -15,11 +15,11 @@ pkgbase = peek
depends = gtk3
depends = libkeybinder3
depends = ffmpeg
- depends = imagemagick
optdepends = gst-plugins-good: WebM output under Gnome Shell
optdepends = gst-plugins-ugly: MP4 output under Gnome Shell
- source = peek-1.1.0.tar.gz::https://github.com/phw/peek/archive/1.1.0.tar.gz
- sha256sums = 3e34be130c43653e849efe9e3e08e446880c11aaf47ec4c62b54c5c5092f4cf9
+ optdepends = gifski: High quality GIF animations with thousands of colors
+ source = peek-1.2.0.tar.gz::https://github.com/phw/peek/archive/1.2.0.tar.gz
+ sha256sums = d6117baca6810d846831653023eb0517138a435a0f85fea9fc1c28421c0ccb2b
pkgname = peek
diff --git a/PKGBUILD b/PKGBUILD
index 0670a45c9fe8..d98cf408b102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
pkgname=peek
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
pkgdesc="Simple screen recorder with an easy to use interface"
arch=('i686' 'x86_64')
url="https://github.com/phw/peek"
license=('GPL3')
-depends=(gtk3 libkeybinder3 ffmpeg imagemagick)
+depends=(gtk3 libkeybinder3 ffmpeg)
makedepends=(cmake vala gettext txt2man)
optdepends=(
'gst-plugins-good: WebM output under Gnome Shell'
'gst-plugins-ugly: MP4 output under Gnome Shell'
+ 'gifski: High quality GIF animations with thousands of colors'
)
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/phw/${pkgname}/archive/${pkgver}.tar.gz)
-sha256sums=('3e34be130c43653e849efe9e3e08e446880c11aaf47ec4c62b54c5c5092f4cf9')
+sha256sums=('d6117baca6810d846831653023eb0517138a435a0f85fea9fc1c28421c0ccb2b')
prepare() {
mkdir -p build
@@ -24,13 +25,15 @@ build() {
cmake "${srcdir}/${pkgname}-${pkgver}" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTS=ON \
- -DGSETTINGS_COMPILE=OFF
+ -DCMAKE_BUILD_TYPE=Release \
+ -DGSETTINGS_COMPILE=OFF \
+ -DENABLE_FILECHOOSERNATIVE=ON
make
}
check() {
cd "build"
- #make test
+ make test
}
package() {