summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeskarune2016-03-30 20:55:55 -0400
committermeskarune2016-03-30 20:55:55 -0400
commit99c485466a2502b697a42517d75cc9d2b30049ea (patch)
treeeffb8034a8d8e638bf1bd39670849ea004c1cb34
parent8cce1065f7237cdb849b2d2fb88d7e8d02f93a2e (diff)
downloadaur-99c485466a2502b697a42517d75cc9d2b30049ea.tar.gz
updated to 71 and updated patch file
-rw-r--r--PKGBUILD14
-rw-r--r--package.patch10
2 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c2d9834db96..1b55107689c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: burntcookie90 <aur at vishnurajeevan dot com>
_gitname=i3lock-fancy
pkgname=i3lock-fancy-git
-pkgver=r70.70cf937
+pkgver=r71.f7a3e3b
pkgrel=1
pkgdesc="i3lock-color script: blurs background, adds lock icon and text, offers dark/light background detection."
arch=('i686' 'x86_64')
@@ -19,12 +19,12 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- patch -N ${srcdir}/${_gitname}/lock ../package.patch
+ patch -N "${srcdir}"/"${_gitname}"/lock ../package.patch
}
package() {
- cd "${srcdir}/$_gitname"
- install -Dm755 lock ${pkgdir}/usr/bin/i3lock-fancy
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${_gitname}/LICENSE
- install -Dm644 lock.png ${pkgdir}/usr/share/${_gitname}/lock.png
- install -Dm644 lockdark.png ${pkgdir}/usr/share/${_gitname}/lockdark.png
+ cd "${srcdir}"/"$_gitname"
+ install -Dm755 lock "${pkgdir}"/usr/bin/i3lock-fancy
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${_gitname}"/LICENSE
+ install -Dm644 lock.png "${pkgdir}"/usr/share/"${_gitname}"/lock.png
+ install -Dm644 lockdark.png "${pkgdir}"/usr/share/"${_gitname}"/lockdark.png
}
diff --git a/package.patch b/package.patch
index c00aef1d494b..d5e1115d37c0 100644
--- a/package.patch
+++ b/package.patch
@@ -1,13 +1,11 @@
---- lock 2016-03-28 10:42:23.087201354 -0400
-+++ lock-new 2016-03-28 10:45:26.600775556 -0400
-@@ -37,9 +37,8 @@
- esac
+--- lock 2016-03-28 13:22:03.804682848 -0400
++++ lock-new 2016-03-30 20:54:48.629852576 -0400
+@@ -38,8 +38,7 @@
done
--# get path where the script is located to find the lock icon
+ # get path where the script is located to find the lock icon
-SCRIPTPATH=$(realpath "$0")
-SCRIPTPATH=${SCRIPTPATH%/*}
-+# path where the lock icons are
+SCRIPTPATH="/usr/share/i3lock-fancy"
# l10n support