summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcondy2023-03-01 23:52:00 +0800
committercondy2023-03-01 23:52:00 +0800
commit9b237f22b1e1fb32716abb55e1d5ff34fa512b2d (patch)
treed699c4605b22b687447ea16ced425c0e74f5792f
parent2002631a501099635b1f5fe1f89d951d23727375 (diff)
downloadaur-9b237f22b1e1fb32716abb55e1d5ff34fa512b2d.tar.gz
Update to 2.0.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f59eba0351c7..59a31f50f4bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-yojson
pkgdesc = Low level JSON binary for OCaml
- pkgver = 1.7.0
- pkgrel = 5
+ pkgver = 2.0.2
+ pkgrel = 1
url = https://github.com/ocaml-community/yojson
arch = x86_64
license = BSD
@@ -14,7 +14,7 @@ pkgbase = ocaml-yojson
conflicts = ocaml-yojson
options = !strip
options = staticlibs
- source = https://github.com/ocaml-community/yojson/releases/download/1.7.0/yojson-1.7.0.tbz
+ source = https://github.com/ocaml-community/yojson/releases/download/2.0.2/yojson-2.0.2.tbz
sha256sums = 656fc65f794186274f8b961dc38daba9e2de2fc993829291defbda2186812cc6
pkgname = ocaml-yojson
diff --git a/PKGBUILD b/PKGBUILD
index 24dcab5a1cbc..132b8f6a0972 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=yojson
pkgname=ocaml-${_pkgname}
-pkgver=1.7.0
-pkgrel=5
+pkgver=2.0.2
+pkgrel=1
pkgdesc="Low level JSON binary for OCaml"
arch=('x86_64')
url="https://github.com/ocaml-community/${_pkgname}"
@@ -15,10 +15,17 @@ conflicts=('ocaml-yojson')
depends=('ocaml' 'ocaml-biniou' 'ocaml-easy-format')
makedepends=('dune' 'cppo')
source=(https://github.com/ocaml-community/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz)
-sha256sums=('656fc65f794186274f8b961dc38daba9e2de2fc993829291defbda2186812cc6')
+sha256sums=('876bb6f38af73a84a29438a3da35e4857c60a14556a606525b148c6fdbe5461b')
build() {
cd ${_pkgname}-${pkgver}
+
+ # no benchmarks
+ rm -rf bench/
+
+ # we're using ocaml > 4.08
+ sed -i '/libraries seq/d' lib/dune
+
make all
}