summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-02-02 18:38:45 -0500
committerTed Alff2017-02-02 18:38:45 -0500
commit9cfb47d8a887e9f7c715ed3c0be9d8a5c9e12c1a (patch)
treead2d0f59b155fe6a1a606222e1b77501719baed3
downloadaur-9cfb47d8a887e9f7c715ed3c0be9d8a5c9e12c1a.tar.gz
Version 2.9.4
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD51
-rw-r--r--linux.gpl19
3 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..835baa7325d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+# Generated by mksrcinfo v8
+# Thu Feb 2 23:38:19 UTC 2017
+pkgbase = gimp-devel
+ pkgdesc = GNU Image Manipulation Program (Development version)
+ pkgver = 2.9.4
+ pkgrel = 1
+ url = http://www.gimp.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = intltool
+ makedepends = poppler-glib
+ makedepends = alsa-lib
+ makedepends = iso-codes
+ makedepends = curl
+ makedepends = ghostscript
+ depends = pygtk
+ depends = lcms
+ depends = libxpm
+ depends = libwmf
+ depends = libxmu
+ depends = librsvg
+ depends = libmng
+ depends = dbus-glib
+ depends = libexif
+ depends = gegl
+ depends = jasper
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = babl
+ depends = openexr
+ depends = libgudev
+ depends = libgexiv2
+ depends = libmypaint>=1.3.0
+ optdepends = gutenprint: for sophisticated printing only as gimp has built-in cups print support
+ optdepends = poppler-glib: for pdf support
+ optdepends = alsa-lib: for MIDI event controller module
+ optdepends = curl: for URI support
+ optdepends = ghostscript: for postscript support
+ provides = gimp=2.9.4
+ conflicts = gimp
+ options = !makeflags
+ source = http://download.gimp.org/pub/gimp/v2.9/gimp-2.9.4.tar.bz2
+ source = linux.gpl
+ sha256sums = c13ac540fd0bd566d7bdd404afe8a04ec0cb1e547788995cd4e8b218c1057b8a
+ sha256sums = 1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3
+
+pkgname = gimp-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d1b68009bc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=gimp
+pkgname=${_pkgname}-devel
+pkgver=2.9.4
+pkgrel=1
+pkgdesc="GNU Image Manipulation Program (Development version)"
+arch=('i686' 'x86_64')
+url="http://www.gimp.org/"
+license=('GPL' 'LGPL')
+depends=('pygtk' 'lcms' 'libxpm' 'libwmf' 'libxmu' 'librsvg' 'libmng' 'dbus-glib'
+ 'libexif' 'gegl' 'jasper' 'desktop-file-utils' 'hicolor-icon-theme' 'babl'
+ 'openexr' 'libgudev' 'libgexiv2' 'libmypaint>=1.3.0')
+makedepends=('intltool' 'poppler-glib' 'alsa-lib' 'iso-codes' 'curl' 'ghostscript')
+optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
+ 'poppler-glib: for pdf support'
+ 'alsa-lib: for MIDI event controller module'
+ 'curl: for URI support'
+ 'ghostscript: for postscript support')
+options=('!makeflags')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}=$pkgver")
+source=(http://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2 linux.gpl)
+sha256sums=('c13ac540fd0bd566d7bdd404afe8a04ec0cb1e547788995cd4e8b218c1057b8a'
+ '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
+ --enable-mp --enable-gimp-console --enable-gimp-remote \
+ --enable-python --with-gif-compression=lzw --with-libcurl \
+ --without-aa --without-hal --without-gvfs --without-gnomevfs
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' "${pkgdir}"/usr/lib/gimp/2.0/plug-ins/*.py
+ install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.0/palettes/Linux.gpl"
+
+ #rm "${pkgdir}/usr/share/man/man1/gimp-console-${pkgver%.*}.1"
+ ln -s gimp-console-${pkgver%.*}.1.gz "${pkgdir}/usr/share/man/man1/gimp-console.1.gz"
+ ln -sf gimptool-2.0.1.gz "${pkgdir}/usr/share/man/man1/gimptool.1.gz"
+ ln -s gimp-${pkgver%.*}.1.gz "${pkgdir}/usr/share/man/man1/gimp.1.gz"
+
+ ln -s gimptool-2.0 "${pkgdir}/usr/bin/gimptool"
+ ln -s gimp-${pkgver%.*} ${pkgdir}/usr/bin/gimp
+ ln -s gimp-console-${pkgver%.*} ${pkgdir}/usr/bin/gimp-console
+}
+
diff --git a/linux.gpl b/linux.gpl
new file mode 100644
index 000000000000..0a73d89793b7
--- /dev/null
+++ b/linux.gpl
@@ -0,0 +1,19 @@
+GIMP Palette
+Name: linux
+#
+ 0 0 0
+ 0 0 170
+ 0 170 0
+ 0 170 170
+170 0 0
+170 0 170
+170 85 0
+170 170 170
+ 85 85 85
+ 85 85 255
+ 85 255 85
+ 85 255 255
+255 85 85
+255 85 255
+255 255 85
+255 255 255