summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroysstu2018-07-14 15:30:30 +0200
committeroysstu2018-07-14 15:30:30 +0200
commit9d5b5473b5b140e41a6940267f269037a3e5dac8 (patch)
tree867ded6600096100f86d261e5fddd29995b5f1e7
downloadaur-9d5b5473b5b140e41a6940267f269037a3e5dac8.tar.gz
v0.9.2
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3faffcd10146
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-paramz
+ pkgdesc = Parameterization Framework for parameterized model creation and handling
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/sods/paramz
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-six
+ depends = python-decorator
+ optdepends = ipython
+ optdepends = python-sphinx
+ optdepends = python-ipykernel
+ optdepends = python-ipywidgets
+ optdepends = python-jupyter_client
+ optdepends = jupyter-notebook
+ source = https://github.com/sods/paramz/archive/v0.9.2.tar.gz
+ sha512sums = cc63e312dd927bab4f82257ada3a74e5ebd7b349ef765f06171cfa2b40876325c20fb28d268e6824adc1dbe350575e77994292dcc74446c5c16ab53c201b6542
+
+pkgname = python-paramz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..202e206f7aab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar.xz
+*.tar.gz
+/pkg/
+/src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6def3c242606
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Oystein Sture <oysstu@gmail.com>
+# Contributor:
+
+pkgname=python-paramz
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="Parameterization Framework for parameterized model creation and handling"
+arch=("any")
+license=("BSD")
+url="https://github.com/sods/paramz"
+depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-decorator')
+optdepends=('ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook')
+makedepends=()
+source=("https://github.com/sods/paramz/archive/v${pkgver}.tar.gz")
+sha512sums=("cc63e312dd927bab4f82257ada3a74e5ebd7b349ef765f06171cfa2b40876325c20fb28d268e6824adc1dbe350575e77994292dcc74446c5c16ab53c201b6542")
+
+build() {
+ cd "paramz-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "paramz-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-paramz/LICENSE"
+}