summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsatcom8862020-06-29 22:00:25 +0200
committersatcom8862020-06-29 22:00:25 +0200
commit9df512432c3c811ba1b4e4fde25d2066135568a0 (patch)
tree2f009cfe1870e252965886f31ba0fa2d7b1a510c
parent42685c7bb36ed3814f5bcc029ec3c168c9e3ad39 (diff)
downloadaur-9df512432c3c811ba1b4e4fde25d2066135568a0.tar.gz
First attempt at separating the packages
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f45593d56e17..fa754ec4bfc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = vc4clstdlib-git
pkgdesc = VC4CL implementation of the OpenCL standard-library and is required to build the VC4C compiler
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/doe300/VC4CLStdLib
arch = any
license = MIT
makedepends = wget
- provides = opencl-pi
- provides = opencl-vc4
- provides = opencl-driver
+ makedepends = make
+ provides = vc4clstdlib
+ provides = vc4-libraries
source = https://github.com/doe300/VC4CLStdLib/archive/master.tar.gz
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b5c1278cf6cb..0fc86d26c1e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,27 @@
pkgname=vc4clstdlib-git
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="VC4CL implementation of the OpenCL standard-library and is required to build the VC4C compiler"
arch=('any')
url="https://github.com/doe300/VC4CLStdLib"
license=('MIT')
groups=()
depends=()
-makedepends=('wget')
+makedepends=('wget' 'make')
optdepends=()
-provides=('opencl-pi' 'opencl-vc4' 'opencl-driver')
+provides=('vc4clstdlib' 'vc4-libraries')
source=("https://github.com/doe300/VC4CLStdLib/archive/master.tar.gz")
md5sums=('SKIP')
-_reponame=VC4CLStdLib
+
+build() {
+ mkdir -p $srcdir/VC4CLStdLib-master/build
+ cd $srcdir/VC4CLStdLib-master/build
+ cmake "$srcdir/VC4CLStdLib-master"
+ make
+}
package() {
- cd $srcdir/$_reponame-master
- mkdir -p $pkgdir/usr/include/$pkgname/include
- cp include/* $pkgdir/usr/include/$pkgname/include/
+ cd $srcdir/VC4CLStdLib-master/build
+ make DESTDIR="$pkgdir"/ install
}