summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2023-09-28 20:51:12 +0200
committerRasmus Karlsson2023-09-28 20:51:12 +0200
commit9f78a9d9401606bd2d86bb2ad740fe065af5ec40 (patch)
tree23941b0ac3449864f73c1535cc1f81e52994cd1f
parentce857b3366b9552093bc6602bd45a14a9a790e5b (diff)
downloadaur-9f78a9d9401606bd2d86bb2ad740fe065af5ec40.tar.gz
patch qt5 hardcoded path in c2
-rw-r--r--.SRCINFO2
-rw-r--r--0001-qt6-qtkeychain.patch13
-rw-r--r--PKGBUILD7
3 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72c62b142868..2c9250c6bfbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,6 +32,7 @@ pkgbase = chatterino2-git
source = git+https://github.com/zaphoyd/websocketpp
source = git+https://github.com/Neargye/magic_enum
source = git+https://github.com/mackron/miniaudio
+ source = 0001-qt6-qtkeychain.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
@@ -43,5 +44,6 @@ pkgbase = chatterino2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 28d74ad28f928e6c1aaab34d4bbda4a1
pkgname = chatterino2-git
diff --git a/0001-qt6-qtkeychain.patch b/0001-qt6-qtkeychain.patch
new file mode 100644
index 000000000000..6194a2fd5783
--- /dev/null
+++ b/0001-qt6-qtkeychain.patch
@@ -0,0 +1,13 @@
+diff --git a/src/common/Credentials.cpp b/src/common/Credentials.cpp
+index d3bb5ebbd..680f290c5 100644
+--- a/src/common/Credentials.cpp
++++ b/src/common/Credentials.cpp
+@@ -11,7 +11,7 @@
+
+ #ifndef NO_QTKEYCHAIN
+ # ifdef CMAKE_BUILD
+-# include "qt5keychain/keychain.h"
++# include "qt6keychain/keychain.h"
+ # else
+ # include "keychain.h"
+ # endif
diff --git a/PKGBUILD b/PKGBUILD
index 8ffdee8d36e9..efa97b0ffe0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,8 @@ source=("git+https://github.com/Chatterino/chatterino2"
"git+https://github.com/Tencent/rapidjson"
"git+https://github.com/zaphoyd/websocketpp"
"git+https://github.com/Neargye/magic_enum"
- "git+https://github.com/mackron/miniaudio")
+ "git+https://github.com/mackron/miniaudio"
+ "0001-qt6-qtkeychain.patch")
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -35,7 +36,8 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '28d74ad28f928e6c1aaab34d4bbda4a1')
pkgver() {
cd "$srcdir/chatterino2"
@@ -58,6 +60,7 @@ prepare () {
git config submodule.lib/miniaudio.url "$srcdir/miniaudio"
git config submodule.lib/magicenum.url "$srcdir/magicenum"
git -c protocol.file.allow=always submodule update
+ patch --forward --strip=1 --input="${srcdir}/0001-qt6-qtkeychain.patch"
}
build() {