summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Price2024-02-25 22:10:37 -0800
committerChristopher Price2024-02-25 22:10:37 -0800
commita02905e3f905282f83e0428ae9edb833e098d8d5 (patch)
treeabf9658e24a17366cf92e3e34631b8563b451d3a
parent04838a70dce5bf53fbf42b66d9d28c8ddc205e6e (diff)
downloadaur-a02905e3f905282f83e0428ae9edb833e098d8d5.tar.gz
Updated to v1.12
-rw-r--r--.SRCINFO12
-rw-r--r--META.camlidl5
-rw-r--r--PKGBUILD24
-rw-r--r--patch.diff14
4 files changed, 43 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c928be97a2c..c2469aff7b14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = camlidl
pkgdesc = A stub code generator and COM binding for Objective Caml (OCaml)
- pkgver = 1.09
+ pkgver = 1.12
pkgrel = 1
url = https://github.com/xavierleroy/camlidl
arch = i686
arch = x86_64
license = LGPL2.1
+ makedepends = git
depends = ocaml
options = staticlibs
- source = https://github.com/xavierleroy/camlidl/archive/camlidl109.tar.gz
+ source = https://github.com/xavierleroy/camlidl/archive/camlidl112.tar.gz
source = META.camlidl
- sha256sums = c6dfe04c08155572b9106cf41540e02c4b4e3f125b903afdd65d154f5f2ceee2
- sha256sums = ed7c8db53b950f62bfe3d1f99081a42787f7b17358dcdcc0e842daacdd5c70b2
+ source = patch.diff
+ sha256sums = d6ab22a363f22798d303df3b0e54ba274f2c3d7ab7a3023fee1c73d8a21970aa
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = camlidl
-
diff --git a/META.camlidl b/META.camlidl
index d18ddf7e04de..4181068747f6 100644
--- a/META.camlidl
+++ b/META.camlidl
@@ -1,5 +1,6 @@
-description = "Stub generator"
-version = "1.06"
+description = "Stub generator from IDL description"
+version = "1.12"
directory = "^"
archive(byte) = "com.cma"
+archive(byte,plugin) = "com.cma"
archive(native) = "com.cmxa"
diff --git a/PKGBUILD b/PKGBUILD
index 553d9fe63474..d4ec0d1eba84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Bertram Felgenhauer <int-e@gmx.de>
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=camlidl
-pkgver=1.09
+pkgver=1.12
_pkgver=${pkgver/\./}
pkgrel=1
pkgdesc="A stub code generator and COM binding for Objective Caml (OCaml)"
@@ -11,13 +11,30 @@ arch=('i686' 'x86_64')
url="https://github.com/xavierleroy/camlidl"
license=(LGPL2.1)
depends=('ocaml')
+makedepends=('git')
options=(staticlibs)
source=("https://github.com/xavierleroy/$pkgname/archive/$pkgname$_pkgver.tar.gz"
- META.camlidl)
+ META.camlidl
+ patch.diff)
+sha256sums=('d6ab22a363f22798d303df3b0e54ba274f2c3d7ab7a3023fee1c73d8a21970aa'
+ 'SKIP'
+ 'SKIP')
build() {
+ #ls -alh
+ cp patch.diff "$srcdir/$pkgname-$pkgname$_pkgver"
+
cd "$srcdir/$pkgname-$pkgname$_pkgver"
cp config/Makefile.unix config/Makefile
+
+ #ls -alh
+ git apply -v patch.diff
+
+ #ls -alh /usr/lib/ocaml/Makefile.config
+ #mkdir -p /build/camlidl/pkg/camlidl//usr/lib/ocaml/
+ #ln -s /usr/lib/ocaml/Makefile.config /build/camlidl/pkg/camlidl//usr/lib/ocaml/Makefile.config
+ #ls -alh /build/camlidl/pkg/camlidl//usr/lib/ocaml/Makefile.config
+
make all
}
@@ -32,6 +49,3 @@ package() {
install -Dm644 "$srcdir/META.camlidl" "$_ocamldir/$pkgname/META"
}
-
-sha256sums=('c6dfe04c08155572b9106cf41540e02c4b4e3f125b903afdd65d154f5f2ceee2'
- 'ed7c8db53b950f62bfe3d1f99081a42787f7b17358dcdcc0e842daacdd5c70b2')
diff --git a/patch.diff b/patch.diff
new file mode 100644
index 000000000000..2a8dd6c206b6
--- /dev/null
+++ b/patch.diff
@@ -0,0 +1,14 @@
+diff --git a/lib/Makefile b/lib/Makefile
+index b5934e5..8c6373b 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -13,7 +13,8 @@
+ #* $Id: Makefile,v 1.4 2002-04-22 11:50:47 xleroy Exp $
+
+ include ../config/Makefile
+-include $(OCAMLLIB)/Makefile.config
++#include $(OCAMLLIB)/Makefile.config
++include /usr/lib/ocaml/Makefile.config
+
+ BYTEOBJS=com.cmo
+ BYTELIB=com.cma