summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Kubica2016-07-12 21:20:35 +0200
committerLukas Werling2016-07-12 22:24:32 +0200
commita08c0c26bd11507490795d00fdf1a72e1d015e80 (patch)
treee182153e7b76657ee9af69f069df3e9143addeda
parented3354d2bfd573510a313c3e9b4eb6eba96a4363 (diff)
downloadaur-a08c0c26bd11507490795d00fdf1a72e1d015e80.tar.gz
GHC 8 fix from Homebrew repository
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b00ce44217a..374e057ed9a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Jul 11 19:52:30 UTC 2016
pkgbase = elm-platform
pkgdesc = Bundle of all core development tools for the Elm language.
pkgver = 0.17.1
- pkgrel = 1
+ pkgrel = 2
url = http://elm-lang.org
arch = i686
arch = x86_64
@@ -20,11 +18,13 @@ pkgbase = elm-platform
source = elm-make-0.17.1.zip::https://github.com/elm-lang/elm-make/archive/0.17.1.zip
source = elm-reactor-0.17.1.zip::https://github.com/elm-lang/elm-reactor/archive/0.17.1.zip
source = elm-repl-0.17.1.zip::https://github.com/elm-lang/elm-repl/archive/0.17.1.zip
+ source = https://github.com/elm-lang/elm-compiler/pull/1431.patch
sha256sums = 3daed1d5099e539945ed2c92cc37c46efed48b32e0adeb37e81788bf400dbd98
sha256sums = fbf34165dc22c1cc8b39750900d6c8644e7d7916377fffb6ddc2ea2eef263637
sha256sums = b948c211e893003e5d55f9ecb2fee8bb44b8d3e04bf778764952d8fd908766b3
sha256sums = b82e9e3220c5edc85321c0d9e524c237e4f2bed61b746e6bfb95af1fb1a53daa
sha256sums = 4f32cd19ae6e85a56703723eb5ba23012109c1571e59c37465eddcfe92d8734b
+ sha256sums = 4f11e645b4190eb3b0cbea7c641d4b28b307b811889f3b8206f45f6e53a5575b
pkgname = elm-platform
diff --git a/PKGBUILD b/PKGBUILD
index e3d34096f497..f2659d9499f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lukas Werling <lukas.werling@gmail.com>
pkgname=elm-platform
pkgver=0.17.1
-pkgrel=1
+pkgrel=2
pkgdesc="Bundle of all core development tools for the Elm language."
arch=('i686' 'x86_64')
url="http://elm-lang.org"
@@ -15,18 +15,25 @@ source=(
elm-make-${pkgver}.zip::https://github.com/elm-lang/elm-make/archive/${pkgver}.zip
elm-reactor-${pkgver}.zip::https://github.com/elm-lang/elm-reactor/archive/${pkgver}.zip
elm-repl-${pkgver}.zip::https://github.com/elm-lang/elm-repl/archive/${pkgver}.zip
+ https://github.com/elm-lang/elm-compiler/pull/1431.patch
)
sha256sums=('3daed1d5099e539945ed2c92cc37c46efed48b32e0adeb37e81788bf400dbd98'
'fbf34165dc22c1cc8b39750900d6c8644e7d7916377fffb6ddc2ea2eef263637'
'b948c211e893003e5d55f9ecb2fee8bb44b8d3e04bf778764952d8fd908766b3'
'b82e9e3220c5edc85321c0d9e524c237e4f2bed61b746e6bfb95af1fb1a53daa'
- '4f32cd19ae6e85a56703723eb5ba23012109c1571e59c37465eddcfe92d8734b')
+ '4f32cd19ae6e85a56703723eb5ba23012109c1571e59c37465eddcfe92d8734b'
+ '4f11e645b4190eb3b0cbea7c641d4b28b307b811889f3b8206f45f6e53a5575b')
prepare() {
cd "$srcdir"
# This is currently necessary to build with GHC 8, see https://github.com/elm-lang/elm-compiler/issues/1397
echo 'allow-newer: aeson,base,HTTP,time,transformers' > cabal.config
+
+ # GHC 8 compat
+ # https://github.com/Homebrew/homebrew-core/blob/8e62a010dbaf0f9626daa2cfae5d2aeea01a65ee/Formula/elm.rb#L43
+ cd elm-compiler-${pkgver}
+ patch -p1 < "$srcdir"/1431.patch
}
# This does not actually use the build script in the elm-lang/elm-platform