summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Prager2022-05-27 12:31:10 +0200
committerMichael Prager2024-03-27 23:19:48 +0100
commita147a415712549315e10eb13464efcd5d20e86d8 (patch)
tree9f7c38b0bccae0015f1c1d33c0080e8a7a7a1ff1
parent4acdc143403cdf46eb64c439212648e508090501 (diff)
downloadaur-a147a415712549315e10eb13464efcd5d20e86d8.tar.gz
added git as makedepends, python as optdepends, changed vlc from depends to optdepends
-rw-r--r--PKGBUILD7
-rw-r--r--gcconfig.pri10
2 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9be2c677d45d..02e6e832ec6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,8 @@ makedepends=(
'make'
'qt5-tools'
'sip4'
- 'pkgconf')
+ 'pkgconf'
+ 'git')
depends=(
'qt5-base'
'qt5-svg'
@@ -29,7 +30,6 @@ depends=(
'qt5-script'
'qt5-connectivity'
'qt5-charts'
- 'vlc'
'gsl')
optdepends=(
'vlc: for video playback in realtime'
@@ -39,7 +39,8 @@ optdepends=(
'libical: for diary integration with Google or MobileMe calendars'
'libusb-compat: for using USB2 sticks in Train View'
'libsamplerate'
- 'r: for charts generation')
+ 'r: for charts generation'
+ 'python: charting / ML')
options=('staticlibs')
conflicts=('golden-cheetah-rc' 'golden-cheetah-dev' 'golden-cheetah')
provides=('golden-cheetah')
diff --git a/gcconfig.pri b/gcconfig.pri
index d8ba7e86355e..eada5b01f8cb 100644
--- a/gcconfig.pri
+++ b/gcconfig.pri
@@ -34,10 +34,12 @@ packagesExist(libR) {
# python3.6-config --libs
#
# below 3 lines work well on Linux style OS
-DEFINES += GC_WANT_PYTHON
-CONFIG += link_pkgconfig
-# Add python3 using pkg-config
-PKGCONFIG += python3 python3-embed
+packagesExist(python3 python3-embed) {
+ DEFINES += GC_WANT_PYTHON
+ CONFIG += link_pkgconfig
+ # Add python3 using pkg-config
+ PKGCONFIG += python3 python3-embed
+}
#PYTHONINCLUDES = -I/usr/include/python3.6
#PYTHONLIBS = -L/usr/lib/python3.6/config-3.6m-x86_64-linux-gnu -lpython3.6m
# below 3 lines work well on Windows