summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitri Goutnik2018-01-22 15:25:16 -0500
committerDmitri Goutnik2018-01-22 15:25:16 -0500
commita295dc6ebd9cd69912f4b5bd2aefd69aeeeefede (patch)
tree77709472ff276db220ebd28d5d3568969260ec6b
parent693b1b22049dad8012211d3b4f09a33c1ce56cd3 (diff)
downloadaur-a295dc6ebd9cd69912f4b5bd2aefd69aeeeefede.tar.gz
Updated: awless 0.1.9-1
Adopt, update to the new upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9abc99440d7d..825b0b2595f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = awless
pkgdesc = A command line interface for Amazon Web Services (AWS)
- pkgver = 0.1.7
+ pkgver = 0.1.9
pkgrel = 1
url = https://github.com/wallix/awless
arch = i686
@@ -8,8 +8,8 @@ pkgbase = awless
license = Apache
makedepends = go
depends = glibc
- source = https://github.com/wallix/awless/archive/v0.1.7.tar.gz
- sha256sums = 583e35c7b93788a37f1b193af9beed1ba351c23ecd15f42318831f2106cd0684
+ source = awless-0.1.9.tar.gz::https://github.com/wallix/awless/archive/v0.1.9.tar.gz
+ sha256sums = eba348663d4ab4695a474ec50633fb784bcbf547c750705870eafa195585d74b
pkgname = awless
diff --git a/PKGBUILD b/PKGBUILD
index 7f6437912831..63c3dddb0918 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
+# Maintainer: Dmitri Goutnik <dg@syrec.org>
# Contributor: Tom Tobin <archlinux@tomxtobin.com>
pkgname=awless
-pkgver=0.1.7
+pkgver=0.1.9
pkgrel=1
pkgdesc="A command line interface for Amazon Web Services (AWS)"
arch=('i686' 'x86_64')
-_vendor="github.com/wallix/${pkgname}"
-url="https://${_vendor}"
+url="https://github.com/wallix/${pkgname}"
license=('Apache')
depends=('glibc')
makedepends=('go')
-source=("https://${_vendor}/archive/v${pkgver}.tar.gz")
-sha256sums=('583e35c7b93788a37f1b193af9beed1ba351c23ecd15f42318831f2106cd0684')
-
-_vendorpath="gopath/src/$_vendor"
+source=("$pkgname-$pkgver.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('eba348663d4ab4695a474ec50633fb784bcbf547c750705870eafa195585d74b')
prepare() {
- mkdir -p $_vendorpath
- mv -T $pkgname-$pkgver $_vendorpath
+ mkdir -p "${srcdir}/src/github.com/wallix/"
+ ln -sf "${srcdir}/${pkgname}-${pkgver}" "${srcdir}/src/github.com/wallix/${pkgname}"
}
build() {
- export GOPATH="$srcdir/gopath"
- cd $_vendorpath
- go build -o bin/$pkgname
+ cd "${srcdir}/src/github.com/wallix/${pkgname}"
+ env GOPATH="${srcdir}" go build -o ${pkgname}
}
+# check() {
+# cd "${srcdir}/src/github.com/wallix/${pkgname}"
+# env GOPATH="${srcdir}" go test ./...
+# }
+
package() {
- cd $_vendorpath
- install -Dm755 bin/$pkgname $pkgdir/usr/bin/$pkgname
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/src/github.com/wallix/${pkgname}"
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}