summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-12-22 14:19:34 +0100
committerJoan Bruguera2019-12-22 14:19:34 +0100
commita49dcfafccc89aba44f2a072b2eb66e1287e172c (patch)
tree3b7750592ec5fc8a22ba297229544639e0294f0b
parent38304c7294a377e879317104343efd7220e35c2d (diff)
downloadaur-a49dcfafccc89aba44f2a072b2eb66e1287e172c.tar.gz
Fix references to the build directory that remain in the package.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--extrae-Fix-references-to-the-build-directory.patch41
3 files changed, 52 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32a78008de9e..2152f6046536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extrae
pkgdesc = Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).
pkgver = 3.7.1.20191001
- pkgrel = 1
+ pkgrel = 2
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = extrae
depends = python
source = https://ftp.tools.bsc.es/extrae/extrae-3.7.1-src.tar.bz2
source = extrae-issue-27-fix-pie-address-translation.patch
+ source = extrae-Fix-references-to-the-build-directory.patch
sha512sums = 51e8f77082069e2aceaae49d15b9f40cb1f9b66810d334f98f4bb5df5a61b8648b25b0a5adec5ab646d18c45f591fb7762a8a7604a8368ff06938d6e86b12a60
sha512sums = 3b0fae157fcc6e85be3a5565c2ea3abe8bf35e130de96435a93ba7b3f4b6c30df8982823d36c494633a2c16671664112558393faeead05226b96aa521bb14fba
+ sha512sums = 1f4e5ab8b375cd456c3f4d0356e33f99d3fd49152b3147a0fdc5317368b1df11bdbda809720c38959c698e885615e961d37a87d3ad6b6b85a3a2caf0c1117db1
pkgname = extrae
diff --git a/PKGBUILD b/PKGBUILD
index f83004383d57..cabd736cf87e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,25 @@
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
pkgver='3.7.1.20191001'
-pkgrel='1'
+pkgrel='2'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(openmpi libunwind papi libxml2 zlib python)
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
- extrae-issue-27-fix-pie-address-translation.patch)
+ extrae-issue-27-fix-pie-address-translation.patch
+ extrae-Fix-references-to-the-build-directory.patch)
sha512sums=(51e8f77082069e2aceaae49d15b9f40cb1f9b66810d334f98f4bb5df5a61b8648b25b0a5adec5ab646d18c45f591fb7762a8a7604a8368ff06938d6e86b12a60
- 3b0fae157fcc6e85be3a5565c2ea3abe8bf35e130de96435a93ba7b3f4b6c30df8982823d36c494633a2c16671664112558393faeead05226b96aa521bb14fba)
+ 3b0fae157fcc6e85be3a5565c2ea3abe8bf35e130de96435a93ba7b3f4b6c30df8982823d36c494633a2c16671664112558393faeead05226b96aa521bb14fba
+ 1f4e5ab8b375cd456c3f4d0356e33f99d3fd49152b3147a0fdc5317368b1df11bdbda809720c38959c698e885615e961d37a87d3ad6b6b85a3a2caf0c1117db1)
prepare() {
cd "$srcdir/$pkgname-${pkgver%.*}"
patch -Np1 -i "$srcdir/extrae-issue-27-fix-pie-address-translation.patch"
+ patch -Np1 -i "$srcdir/extrae-Fix-references-to-the-build-directory.patch"
+
+ autoreconf -i -f
}
build() {
diff --git a/extrae-Fix-references-to-the-build-directory.patch b/extrae-Fix-references-to-the-build-directory.patch
new file mode 100644
index 000000000000..a49882746d47
--- /dev/null
+++ b/extrae-Fix-references-to-the-build-directory.patch
@@ -0,0 +1,41 @@
+From 34f3652fdbe58bb2224cb4ecf8a4ea08200a4034 Mon Sep 17 00:00:00 2001
+From: Joan Bruguera <joanbrugueram@gmail.com>
+Date: Sun, 22 Dec 2019 13:35:23 +0100
+Subject: [PATCH] Fix references to the build directory that remain in the
+ packages. (Fixes the "Package contains reference to $pkgdir" makepkg
+ warning).
+
+---
+ src/others/Makefile.am | 2 +-
+ tests/overhead/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/others/Makefile.am b/src/others/Makefile.am
+index cb2a75b..c52d434 100644
+--- a/src/others/Makefile.am
++++ b/src/others/Makefile.am
+@@ -40,7 +40,7 @@ endif
+
+ install-data-hook:
+ cp pyextrae/common/extrae.py.in pyextrae/common/extrae.py
+- $(top_srcdir)/substitute $(SED) "@sub_PREFIX@" $(DESTDIR)${prefix} pyextrae/common/extrae.py
++ $(top_srcdir)/substitute $(SED) "@sub_PREFIX@" ${prefix} pyextrae/common/extrae.py
+ #if HAVE_PAPI
+ $(top_srcdir)/substitute $(SED) "@sub_Extrae_eventandcounters@" Extrae_eventandcounters pyextrae/common/extrae.py
+ $(top_srcdir)/substitute $(SED) "@sub_Extrae_neventandcounters@" Extrae_neventandcounters pyextrae/common/extrae.py
+diff --git a/tests/overhead/Makefile.am b/tests/overhead/Makefile.am
+index 67b3c92..093c177 100644
+--- a/tests/overhead/Makefile.am
++++ b/tests/overhead/Makefile.am
+@@ -72,7 +72,7 @@ install-data-hook:
+ $(MKDIR_P) $(DESTDIR)$(datadir)/tests/overhead
+ cp $(myFILES) $(DESTDIR)$(datadir)/tests/overhead
+ cp $(myPATH)/Makefile.tests.overhead $(DESTDIR)$(datadir)/tests/overhead/Makefile
+- $(BASE_DIR)/substitute $(SED) "@sub_EXTRAE_HOME@" "$(DESTDIR)$(prefix)" $(DESTDIR)$(datadir)/tests/overhead/run_overhead_tests.sh
++ $(BASE_DIR)/substitute $(SED) "@sub_EXTRAE_HOME@" "$(prefix)" $(DESTDIR)$(datadir)/tests/overhead/run_overhead_tests.sh
+ if HAVE_PAPI
+ $(BASE_DIR)/substitute $(SED) "@sub_COUNTERS_OVERHEAD_TESTS@" "./extrae_eventandcounters ./papi_read1 ./papi_read4" $(DESTDIR)$(datadir)/tests/overhead/run_overhead_tests.sh
+ endif
+--
+2.24.1
+