summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Sommer2019-07-08 02:00:51 +0200
committerRoman Sommer2019-07-08 02:06:39 +0200
commita5a380401fdc02ec2bec47fca4bbf3ec6d304a21 (patch)
treed8fec13cc841f14df4a203a6a5fa4223c46da3eb
downloadaur-a5a380401fdc02ec2bec47fca4bbf3ec6d304a21.tar.gz
add files for v1.51
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--0001-Shape.h-add-missing-header.patch27
-rw-r--r--PKGBUILD73
-rw-r--r--veroroute-clib.scm27
-rw-r--r--veroroute.desktop.in12
6 files changed, 163 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6eaa3710cb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = veroroute
+ pkgdesc = Qt based Veroboard/Perfboard/PCB layout and routing application
+ pkgver = 1.51
+ pkgrel = 1
+ url = https://sourceforge.net/projects/veroroute
+ arch = i686
+ arch = x86_64
+ license = GPLv3+
+ depends = qt5-base
+ depends = geda-gaf
+ source = https://downloads.sourceforge.net/project/veroroute/VeroRoute_V151_Src.zip
+ source = veroroute.desktop.in
+ source = veroroute-clib.scm
+ source = 0001-Shape.h-add-missing-header.patch
+ sha256sums = 773611e8fe7bb7ea2fc4bbd83a83b1308fdb19ef1ac8cbe752c286cb91bf6edb
+ sha256sums = bbf5a01f8f05909f52cee36ac0184c039aca313d078bcced47dcdcfcaa26bba9
+ sha256sums = a722805c46998bff7709357babc2e609fbc4b0021b33c59aefa4f7fa0567aeeb
+ sha256sums = b9b397b0fd2ac437d84b410e380b8337a1c2432aef61721b93be3062bdb70cda
+
+pkgname = veroroute
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d92c19c88b77
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*~
+\#*\#
+.\#*
diff --git a/0001-Shape.h-add-missing-header.patch b/0001-Shape.h-add-missing-header.patch
new file mode 100644
index 000000000000..f6746b72312b
--- /dev/null
+++ b/0001-Shape.h-add-missing-header.patch
@@ -0,0 +1,27 @@
+From 2c28cbf6c02bb38c7235ee1a613a37427daaff7d Mon Sep 17 00:00:00 2001
+From: Roman Sommer <roman.sommer@fau.de>
+Date: Sun, 7 Jul 2019 22:16:39 +0200
+Subject: [VeroRoute] [PATCH] Shape.h: add missing header
+
+This patch adds a missing header to fix compilation with qmake under
+Arch Linux.
+
+---
+ Src/Shape.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Src/Shape.h b/Src/Shape.h
+index 94852ee..df76b79 100644
+--- a/Src/Shape.h
++++ b/Src/Shape.h
+@@ -19,6 +19,7 @@
+
+ #pragma once
+
++#include <cmath>
+ #include "Persist.h"
+ #include "Rect.h"
+
+--
+2.22.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1e6b33d68f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Roman Sommer <roman.sommer@fau.de>
+pkgname=veroroute
+_pkgvermajor=1
+_pkgverminor=51
+pkgver=$_pkgvermajor.$_pkgverminor
+pkgrel=1
+epoch=
+pkgdesc="Qt based Veroboard/Perfboard/PCB layout and routing application"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/veroroute"
+license=('GPLv3+')
+groups=()
+depends=(qt5-base geda-gaf)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+_sourcearchive="VeroRoute_V${_pkgvermajor}${_pkgverminor}_Src.zip"
+source=("https://downloads.sourceforge.net/project/$pkgname/$_sourcearchive"
+ "veroroute.desktop.in"
+ "veroroute-clib.scm"
+ "0001-Shape.h-add-missing-header.patch")
+sha256sums=('773611e8fe7bb7ea2fc4bbd83a83b1308fdb19ef1ac8cbe752c286cb91bf6edb'
+ 'bbf5a01f8f05909f52cee36ac0184c039aca313d078bcced47dcdcfcaa26bba9'
+ 'a722805c46998bff7709357babc2e609fbc4b0021b33c59aefa4f7fa0567aeeb'
+ 'b9b397b0fd2ac437d84b410e380b8337a1c2432aef61721b93be3062bdb70cda')
+noextract=()
+
+prepare() {
+ echo "$srcdir"
+ cd "$srcdir/VeroRoute"
+
+ patch -p1 -i "../0001-Shape.h-add-missing-header.patch"
+ sed -e "s|__VERSION__|${pkgver}|g" -e "s|__COMMENT__|${pkgdesc}|g" $srcdir/veroroute.desktop.in > $srcdir/veroroute.desktop
+}
+
+build() {
+ cd "$srcdir/VeroRoute"
+ mkdir -p build
+ cd build
+ qmake ../Src
+ make
+}
+
+check() {
+ cd "$srcdir/VeroRoute/build"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/VeroRoute"
+ install -Dm755 VeroRoute "$pkgdir/usr/bin/veroroute"
+ mkdir -p "$pkgdir/usr/share/pixmaps/"
+ install -Dm644 VeroRoute.png "$pkgdir/usr/share/pixmaps/"
+ mkdir -p "$pkgdir/usr/share/applications/"
+ install -Dm644 "$srcdir/veroroute.desktop" "$pkgdir/usr/share/applications/"
+ mkdir -p "$pkgdir/usr/share/veroroute/Tutorials"
+ find Tutorials -maxdepth 1 -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/veroroute/Tutorials" \;
+ mkdir -p "$pkgdir/usr/share/veroroute/Templates"
+ find Templates -maxdepth 1 -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/veroroute/Templates" \;
+ mkdir -p "$pkgdir/usr/share/gEDA/sym"
+ (cd Libraries/gEDA; find . -mindepth 2 -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/gEDA/sym/{}" \;)
+ mkdir -p "$pkgdir/usr/share/gEDA/gafrc.d/"
+ install -Dm644 "$srcdir/veroroute-clib.scm" "$pkgdir/usr/share/gEDA/gafrc.d/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/veroroute-clib.scm b/veroroute-clib.scm
new file mode 100644
index 000000000000..75b9fe67607b
--- /dev/null
+++ b/veroroute-clib.scm
@@ -0,0 +1,27 @@
+; -*-Scheme-*-
+;;;
+;;; Add component libraries for veroroute
+;;;
+
+(define geda-sym-path (build-path geda-data-path "sym"))
+
+(for-each
+ (lambda (dir)
+ (if (list? dir)
+ (component-library (build-path geda-sym-path (car dir)) (cadr dir))
+ (component-library (build-path geda-sym-path dir)))
+ )
+ (reverse '(
+ ; VeroRoute symbols
+ ("veroroute_battery" "VeroRoute Battery")
+ ("veroroute_bbd" "VeroRoute BBD")
+ ("veroroute_connector" "VeroRoute Connector")
+ ("veroroute_diode" "VeroRoute Diode")
+ ("veroroute_electromechanical" "VeroRoute ElectroMechanical")
+ ("veroroute_linear" "VeroRoute Linear")
+ ("veroroute_logic" "VeroRoute Logic")
+ ("veroroute_passive" "VeroRoute Passive")
+ ("veroroute_regulator" "VeroRoute Regulator")
+ ("veroroute_spin" "VeroRoute Spin")
+ ("veroroute_transistor" "VeroRoute Transistor")
+ )))
diff --git a/veroroute.desktop.in b/veroroute.desktop.in
new file mode 100644
index 000000000000..63c317e0a9ff
--- /dev/null
+++ b/veroroute.desktop.in
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Categories=Development;Electronics
+Comment=__COMMENT__
+Encoding=UTF-8
+Exec=/usr/bin/veroroute
+Icon=/usr/share/pixmaps/VeroRoute.png
+Name=VeroRoute
+Path=/usr/share/veroroute/
+StartupNotify=false
+Terminal=false
+Type=Application
+Version=__VERSION__