summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornotEvil2023-06-25 00:59:18 +0200
committernotEvil2023-06-25 00:59:18 +0200
commita60762bfb12b744682f38df0f76064eb90512a92 (patch)
treea066ac3b8502e53aaa06c448c006c3a176ee5e89
parentbaa50ee526624ede2f3c79d95a07f6d3a9b22f5d (diff)
downloadaur-a60762bfb12b744682f38df0f76064eb90512a92.tar.gz
Updated to version 3.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--patch11
3 files changed, 5 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 434c8ff1d911..100657a760f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-bokeh
pkgdesc = Interactive Web Plotting for Python
- pkgver = 3.1.1
+ pkgver = 3.2.0
pkgrel = 1
url = http://bokeh.pydata.org/
arch = any
@@ -23,7 +23,7 @@ pkgbase = python-bokeh
optdepends = python-psutil: detailed memory logging
optdepends = python-networkx: plot directly from NetworkX data
optdepends = python-sphinx: support sphinx documentation
- source = https://pypi.io/packages/source/b/bokeh/bokeh-3.1.0.tar.gz
- sha256sums = 1c28471ef5e6110ba5bed513137fd26054ebc4454bc768650eaeefc53b898a8a
+ source = https://pypi.io/packages/source/b/bokeh/bokeh-3.2.0.tar.gz
+ sha256sums = cdb3a8c3109d8d91a2814f4cddea045c14d049021f7fb6ce2a6b2c15e224bb17
pkgname = python-bokeh
diff --git a/PKGBUILD b/PKGBUILD
index 48509982cee3..b6c39c07feee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Excitable Snowball <excitablesnowball@gmail.com>
pkgname=python-bokeh
-pkgver=3.1.1
+pkgver=3.2.0
pkgrel=1
pkgdesc='Interactive Web Plotting for Python'
arch=('any')
@@ -10,11 +10,9 @@ url='http://bokeh.pydata.org/'
license=('BSD')
source=(
"https://pypi.io/packages/source/b/bokeh/bokeh-$pkgver.tar.gz"
- 'patch'
)
sha256sums=(
- 'ba0fc6bae4352d307541293256dee930a42d0acf92e760c72dc0e7397c3a28e9'
- 'cb7cf3d3189282521206a04ad32f1cbb2667a408426ece88b4f3d26bb873e9b9'
+ 'cdb3a8c3109d8d91a2814f4cddea045c14d049021f7fb6ce2a6b2c15e224bb17'
)
depends=('python-jinja'
'python-contourpy'
@@ -34,10 +32,6 @@ optdepends=('python-selenium: svg export'
'python-sphinx: support sphinx documentation')
makedepends=('python-build' 'python-installer')
-prepare() {
- patch -d "$srcdir/bokeh-$pkgver" -p1 < ./patch # workaround for https://github.com/bokeh/bokeh/issues/13122
-}
-
build() {
cd "$srcdir/bokeh-$pkgver"
python -m build --wheel
diff --git a/patch b/patch
deleted file mode 100644
index 79d14e0ee0ae..000000000000
--- a/patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./setup.py 2023-05-10 23:29:34.694515891 +0200
-+++ ./setup.py.new 2023-05-10 23:30:12.840773479 +0200
-@@ -156,7 +156,7 @@
-
- class Build(build): # type: ignore
- def run(self) -> None:
-- check_tags()
-+ # check_tags()
- build_or_install_bokehjs(self.distribution.packages)
- super().run()
-