summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-11-26 01:20:53 +0100
committerDaniel Peukert2023-11-26 01:20:53 +0100
commita65785608fb9603ac76eb6716ea6102d91e78a64 (patch)
tree5889124b9b3d0e78aa50f0480b26af58703d8cb9
parent1eefbab2b900dafc8e5a00c02159858e2efb98e2 (diff)
downloadaur-a65785608fb9603ac76eb6716ea6102d91e78a64.tar.gz
Add amdvbflash
-rw-r--r--.SRCINFO13
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD31
4 files changed, 40 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6007b838cde3..e509184f28dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = amdvbflash
- pkgdesc = AMD vBIOS flash utility.
- pkgver = v4.71
+ pkgdesc = AMD vBIOS flash utility
+ pkgver = 4.104e
pkgrel = 1
- url = https://github.com/stylesuxx/amdvbflash
+ url = https://www.techpowerup.com/forums/threads/amdvbflash-4-104e-for-64-bit-linux-with-updated-support-for-vbios-flash-on-big-navi2x-gpus.313927/post-5106820
arch = x86_64
- license = custom
- source = git+https://github.com/stylesuxx/amdvbflash.git
- md5sums = SKIP
+ license = unknown
+ source = amdvbflash-4.104e.zip::https://www.techpowerup.com/forums/attachments/amdvbflash4-104e-linux-zip.314661/
+ sha512sums = 56eace73c377f9c57344618a168155a2af3a8895f343717a70decdd1fb4beb2a6c367f02e7a7f7e334e332d234df3cee61d022c65962fb3dcf061f382bdbbc2b
pkgname = amdvbflash
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..004b0a3a8706
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 75d7f44ddf60..3401e18cbde4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,16 @@
-pkgname=amdvbflash
-pkgver=v4.71
-pkgrel=1
-pkgdesc="AMD vBIOS flash utility."
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
+# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
+pkgname='amdvbflash'
+pkgver='4.104e'
+pkgrel='1'
+pkgdesc='AMD vBIOS flash utility'
arch=('x86_64')
-url="https://github.com/stylesuxx/amdvbflash"
-license=('custom')
-depends=()
-
-source=("git+https://github.com/stylesuxx/amdvbflash.git")
-md5sums=('SKIP')
-
-#pkgver() {
-# cd amdvbflash
-# git describe --tags
-#}
+url="https://www.techpowerup.com/forums/threads/amdvbflash-4-104e-for-64-bit-linux-with-updated-support-for-vbios-flash-on-big-navi2x-gpus.313927/post-5106820"
+license=('unknown')
+source=("$pkgname-$pkgver.zip::https://www.techpowerup.com/forums/attachments/amdvbflash4-104e-linux-zip.314661/")
+sha512sums=('56eace73c377f9c57344618a168155a2af3a8895f343717a70decdd1fb4beb2a6c367f02e7a7f7e334e332d234df3cee61d022c65962fb3dcf061f382bdbbc2b')
package() {
- cd amdvbflash
- mkdir -p "$pkgdir/usr/bin"
- install -m 755 "amdvbflash" "$pkgdir/usr/bin"
+ cd "$srcdir/"
+ install -Dm755 'amdvbflash4-104E' "$pkgdir/usr/bin/$pkgname"
}
-