summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirco Tischler2015-11-18 23:36:38 +0100
committerMirco Tischler2015-11-18 23:36:38 +0100
commita9b20a624f75a0b83702b5e9113a7e068d1f1d37 (patch)
tree67ff57348e501087fc8c895cfe5038502232c66c
parent48ca59832e289284f3ce520db596fe54b9f5fafd (diff)
downloadaur-a9b20a624f75a0b83702b5e9113a7e068d1f1d37.tar.gz
fwupdate: version 0.5-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a973fba9e589..79f3eda70357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = fwupdate
pkgdesc = Tools for using the ESRT and UpdateCapsule() to apply firmware updates
- pkgver = 0.4
- pkgrel = 2
+ pkgver = 0.5
+ pkgrel = 1
url = https://github.com/rhinstaller/fwupdate
arch = i686
arch = x86_64
license = GPL2
makedepends = pesign
+ makedepends = gnu-efi-libs
depends = efivar
- depends = gnu-efi-libs
- source = fwupdate-0.4.tar.gz::https://github.com/rhinstaller/fwupdate/archive/0.4.tar.gz
- sha256sums = 83ec7b2bf8d3bc37c6a60044d964503233c359150bcdb6f30e9f01ef1edd97dd
+ source = https://github.com/rhinstaller/fwupdate/releases/download/0.5/fwupdate-0.5.tar.bz2
+ sha256sums = 633cd81e5120857ca4ab94067a59e56a031bb3764584ce1fcfe4fdb9c71031d5
pkgname = fwupdate
diff --git a/PKGBUILD b/PKGBUILD
index 23be7ee04328..adb8fddff00f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Mirco Tischler <mt-ml at gmx dot de>
pkgname=fwupdate
-pkgver=0.4
-pkgrel=2
+pkgver=0.5
+pkgrel=1
pkgdesc='Tools for using the ESRT and UpdateCapsule() to apply firmware updates'
arch=('i686' 'x86_64')
url='https://github.com/rhinstaller/fwupdate'
license=('GPL2')
-depends=('efivar' 'gnu-efi-libs')
-makedepends=('pesign')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('83ec7b2bf8d3bc37c6a60044d964503233c359150bcdb6f30e9f01ef1edd97dd')
+depends=('efivar')
+makedepends=('pesign' 'gnu-efi-libs')
+source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('633cd81e5120857ca4ab94067a59e56a031bb3764584ce1fcfe4fdb9c71031d5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -21,10 +21,12 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make LIBDIR=/usr/lib DESTDIR="${pkgdir}" install
+ make LIBDIR=/usr/lib DESTDIR="${pkgdir}" libexecdir=/usr/lib/ install
#don't install into /boot. copy files to /usr/lib/fwupdate for manual installation
install -d ${pkgdir}/usr/lib/fwupdate
mv ${pkgdir}/boot/efi/EFI ${pkgdir}/usr/lib/fwupdate/EFI
rm -rf ${pkgdir}/boot
+ rm -rf ${pkgdir}/usr/src
+ rm -rf ${pkgdir}/usr/lib/debug
}