summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2022-08-26 16:08:52 +0430
committerBehnam Momeni2022-08-26 16:08:52 +0430
commita9e6d36ff340ac9306f04595fe22e671d92a7d99 (patch)
tree5a56625ccf06d35f81a62ec38cf98f6785428465
parent69c737bd11ea47f2abfb737efa0ac913998f4fff (diff)
downloadaur-a9e6d36ff340ac9306f04595fe22e671d92a7d99.tar.gz
Add missing AVCodecContext forward declaration
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--fix_ffmpeg5.patch18
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2feca36de28e..f28d86ca7492 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Aug 26 10:20:33 UTC 2022
+# Fri Aug 26 11:38:32 UTC 2022
pkgbase = bombono-dvd
pkgdesc = DVD authoring program with nice and clean GUI
pkgver = 1.2.4
- pkgrel = 7
+ pkgrel = 8
url = http://www.bombono.org
install = bombono-dvd.install
arch = i686
@@ -45,7 +45,7 @@ pkgbase = bombono-dvd
sha256sums = 72b3d6c76cbf98fb9287f7ee5b7a57b6febe2a635d50758c2451e376e3e6ca02
sha256sums = 9d56f7d16c55a506b092dbec00789e4767963d6202d3d92b79ad389393d43c69
sha256sums = f6fd3a309987ac08b6f70132686c5a06bc7496fb6e1097539d6348f558d09502
- sha256sums = 45432a2c089f975f5ee04270c878ef61b98a6b114f2618cc47e61221b3a808ee
+ sha256sums = bab551ef9733eb67c1e036becec0600c31479fbdf49f6e3b4380efdcbdae726c
pkgname = bombono-dvd
diff --git a/PKGBUILD b/PKGBUILD
index 22d523b59026..cf04fa399889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bombono-dvd
pkgver=1.2.4
-pkgrel=7
+pkgrel=8
pkgdesc="DVD authoring program with nice and clean GUI"
arch=('i686' 'x86_64')
url="http://www.bombono.org"
@@ -35,7 +35,7 @@ sha256sums=('4f8c882a0c359ca8c182a627885c64aa271820eead2f9a64b34f1625c3b0a9d7'
'72b3d6c76cbf98fb9287f7ee5b7a57b6febe2a635d50758c2451e376e3e6ca02'
'9d56f7d16c55a506b092dbec00789e4767963d6202d3d92b79ad389393d43c69'
'f6fd3a309987ac08b6f70132686c5a06bc7496fb6e1097539d6348f558d09502'
- '45432a2c089f975f5ee04270c878ef61b98a6b114f2618cc47e61221b3a808ee')
+ 'bab551ef9733eb67c1e036becec0600c31479fbdf49f6e3b4380efdcbdae726c')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/fix_ffmpeg5.patch b/fix_ffmpeg5.patch
index 28cfa0aad61a..371afa0388b2 100644
--- a/fix_ffmpeg5.patch
+++ b/fix_ffmpeg5.patch
@@ -1,6 +1,6 @@
diff -ruN old/src/mgui/ffviewer.cpp new/src/mgui/ffviewer.cpp
---- old/src/mgui/ffviewer.cpp 2022-08-26 11:00:17.936924594 +0430
-+++ new/src/mgui/ffviewer.cpp 2022-08-26 14:41:31.887225381 +0430
+--- old/src/mgui/ffviewer.cpp 2022-08-26 15:51:35.995797128 +0430
++++ new/src/mgui/ffviewer.cpp 2022-08-26 15:56:06.538840475 +0430
@@ -37,6 +37,7 @@
#endif
@@ -126,8 +126,16 @@ diff -ruN old/src/mgui/ffviewer.cpp new/src/mgui/ffviewer.cpp
{
diff -ruN old/src/mgui/ffviewer.h new/src/mgui/ffviewer.h
--- old/src/mgui/ffviewer.h 2016-04-10 15:15:39.000000000 +0430
-+++ new/src/mgui/ffviewer.h 2022-08-26 11:25:10.616129717 +0430
-@@ -70,6 +70,7 @@
++++ new/src/mgui/ffviewer.h 2022-08-26 16:00:47.375606645 +0430
+@@ -53,6 +53,7 @@
+ //
+ typedef FFViewer VideoViewer;
+
++struct AVCodecContext;
+ struct FFData;
+ double FrameFPS(FFData& ffv);
+ double Duration(FFData& ffv);
+@@ -70,6 +71,7 @@
struct FFData: public boost::noncopyable
{
AVFormatContext* iCtx;
@@ -137,7 +145,7 @@ diff -ruN old/src/mgui/ffviewer.h new/src/mgui/ffviewer.h
diff -ruN old/src/mgui/project/media-browser.cpp new/src/mgui/project/media-browser.cpp
--- old/src/mgui/project/media-browser.cpp 2016-04-10 15:15:39.000000000 +0430
-+++ new/src/mgui/project/media-browser.cpp 2022-08-26 14:08:22.610955145 +0430
++++ new/src/mgui/project/media-browser.cpp 2022-08-26 15:56:06.538840475 +0430
@@ -240,8 +240,8 @@
a_cnt = 0;
for( int i=0; i < (int)ic->nb_streams; i++ )