summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2020-05-31 11:19:13 -0700
committerKartik Mohta2020-05-31 11:19:13 -0700
commitab278bad3e40d99b37ca14d0a62a8b60ac7c1242 (patch)
tree32f78e018eec238145c5b995ffcd42a4019e3def
parentbb9286c21cc3c7f92b5bd637a437a812c83ce892 (diff)
downloadaur-ab278bad3e40d99b37ca14d0a62a8b60ac7c1242.tar.gz
Switch source to github repo
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed41e11f4a40..c4a5d7f440eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python2-rospkg
- pkgdesc = ROS package library
+ pkgdesc = Standalone Python library for the ROS package system
pkgver = 1.2.6
- pkgrel = 1
- url = http://wiki.ros.org/rospkg
+ pkgrel = 2
+ url = https://github.com/ros-infrastructure/rospkg
arch = any
license = BSD
makedepends = python2-setuptools
@@ -10,8 +10,8 @@ pkgbase = python2-rospkg
depends = python2-catkin_pkg
depends = python2-yaml
conflicts = python-rospkg
- source = https://files.pythonhosted.org/packages/source/r/rospkg/rospkg-1.2.6.tar.gz
- sha256sums = 3a27f5037afeba796449b30ad77cb1085fc65f8be10e75e40dbcc3777f83c1a6
+ source = https://github.com/ros-infrastructure/rospkg/archive/1.2.6.tar.gz
+ sha256sums = 6fec215df97895b3906660fed736544b7232635dd3a62e6a8aae553159e67ac2
pkgname = python2-rospkg
diff --git a/PKGBUILD b/PKGBUILD
index ab3224a24cbf..eeff31c6af44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python2-rospkg'
pkgname=('python2-rospkg')
-_module='rospkg'
pkgver='1.2.6'
-pkgrel=1
-pkgdesc="ROS package library"
-url="http://wiki.ros.org/rospkg"
+pkgrel=2
+pkgdesc='Standalone Python library for the ROS package system'
+arch=('any')
+url='https://github.com/ros-infrastructure/rospkg'
+license=('BSD')
depends=('python2' 'python2-catkin_pkg' 'python2-yaml')
-conflicts=('python-rospkg')
makedepends=('python2-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('3a27f5037afeba796449b30ad77cb1085fc65f8be10e75e40dbcc3777f83c1a6')
+
+conflicts=('python-rospkg')
+source=("https://github.com/ros-infrastructure/rospkg/archive/${pkgver}.tar.gz")
+sha256sums=('6fec215df97895b3906660fed736544b7232635dd3a62e6a8aae553159e67ac2')
+
+_module='rospkg'
build() {
cd "${srcdir}/${_module}-${pkgver}"