summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2018-08-13 21:10:38 +0200
committerDavid Runge2018-08-13 21:10:38 +0200
commitab56da8491fc57e2362376bdbe1fa7498006749e (patch)
tree653a021d5737969d28a28f73d79d626c8386e179
parent0085841059f3a85a4c83f05a131c70e458106ea2 (diff)
downloadaur-ab56da8491fc57e2362376bdbe1fa7498006749e.tar.gz
PKGBUILD: Adding boost 1.67.0 patch for supernova. Cleaning up depends, optdepends and makedepends. Updating pkgver according to (now fixed) upstream tagging system.
Properly building with system boost and yaml-cpp. Adding docs. Minor fixes.
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD66
-rw-r--r--boost-1.67.patch12
3 files changed, 58 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db594224bb84..8e1d46aebe13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,45 +1,43 @@
-# Generated by mksrcinfo v8
-# Mon Oct 30 22:18:57 UTC 2017
pkgbase = supercollider-git
- pkgdesc = An environment and programming language for real time audio synthesis and algorithmic composition.
- pkgver = 3.8.0.r2149.gcca12ff02
- pkgrel = 2
+ pkgdesc = Environment and programming language for real time audio synthesis and algorithmic composition
+ pkgver = 3.9.3.r783.g88621c5f91
+ pkgrel = 1
url = https://supercollider.github.io/
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
license = GPL3
- makedepends = avahi
makedepends = boost
makedepends = cmake
makedepends = emacs
- makedepends = libsndfile
+ makedepends = git
makedepends = qt5-tools
- makedepends = ruby
- makedepends = vim
- depends = jack
+ depends = boost-libs
depends = fftw
- depends = cwiid
- depends = qt5-webkit
+ depends = jack
+ depends = qt5-webengine
+ depends = qt5-svg
+ depends = yaml-cpp
optdepends = emacs: emacs interface
optdepends = gedit: gedit interface
+ optdepends = sc3-plugins: additional extension plugins for scsynth
provides = supercollider
conflicts = supercollider
source = git+https://github.com/supercollider/supercollider.git
source = git+https://github.com/timblechmann/nova-simd.git
source = git+https://github.com/timblechmann/nova-tt.git
source = git+https://github.com/supercollider/hidapi.git
- source = git+https://github.com/supercollider/scvim.git
source = git+https://github.com/supercollider/portaudio.git
source = git+https://github.com/supercollider/yaml-cpp.git
+ source = boost-1.67.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = SKIP
+ sha512sums = 9980d77802f18fd56d2a13f24f070e81768d9111b2cc63e479a0e9b405a04aec28bc523e5d36aab0462af6a3831d64598470cdc6c3266431e2ca64aa427a6bf2
pkgname = supercollider-git
diff --git a/PKGBUILD b/PKGBUILD
index d7e255caf36a..4343081fcd7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,60 @@
# Maintainer: David Runge <dave@sleepmap.de>
pkgname=supercollider-git
-_pkg="supercollider"
-_latest_tag="3.8.0"
-pkgver=3.8.0.r2149.gcca12ff02
-pkgrel=2
-pkgdesc="An environment and programming language for real time audio synthesis and algorithmic composition."
+_name="supercollider"
+pkgver=3.9.3.r783.g88621c5f91
+pkgrel=1
+pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://supercollider.github.io/"
license=('GPL3')
-depends=('jack' 'fftw' 'cwiid' 'qt5-webkit')
-makedepends=('avahi' 'boost' 'cmake' 'emacs' 'libsndfile' 'qt5-tools' 'ruby' 'vim')
+depends=('boost-libs' 'fftw' 'jack' 'qt5-webengine' 'qt5-svg' 'yaml-cpp')
+makedepends=('boost' 'cmake' 'emacs' 'git' 'qt5-tools')
optdepends=('emacs: emacs interface'
- 'gedit: gedit interface')
+ 'gedit: gedit interface'
+ 'sc3-plugins: additional extension plugins for scsynth')
conflicts=('supercollider')
provides=('supercollider')
-source=("git+https://github.com/supercollider/supercollider.git"
+source=("git+https://github.com/${_name}/${_name}.git"
"git+https://github.com/timblechmann/nova-simd.git"
"git+https://github.com/timblechmann/nova-tt.git"
- "git+https://github.com/supercollider/hidapi.git"
- "git+https://github.com/supercollider/scvim.git"
- "git+https://github.com/supercollider/portaudio.git"
- "git+https://github.com/supercollider/yaml-cpp.git")
+ "git+https://github.com/${_name}/hidapi.git"
+ "git+https://github.com/${_name}/portaudio.git"
+ "git+https://github.com/${_name}/yaml-cpp.git"
+ 'boost-1.67.patch')
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ '9980d77802f18fd56d2a13f24f070e81768d9111b2cc63e479a0e9b405a04aec28bc523e5d36aab0462af6a3831d64598470cdc6c3266431e2ca64aa427a6bf2')
pkgver() {
- cd "${_pkg}"
- # Version according to chaotic tagging:
- # https://github.com/supercollider/supercollider/issues/2857
- git describe | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/Version.3.7.2/'"$_latest_tag"'/g'
+ cd "${_name}"
+ git describe --long --tags | sed 's/Version-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${_pkg}"
+ cd "${_name}"
git submodule init
git config submodule.external_libraries/nova-simd.url "${srcdir}/nova-simd"
git config submodule.external_libraries/nova-tt.url "${srcdir}/nova-tt"
git config submodule.external_libraries/hidapi.url "${srcdir}/hidapi"
- git config submodule.editors/scvim.url "${srcdir}/scvim"
git config submodule.external_libraries/portaudio_sc_org.url "${srcdir}/portaudio"
- git config submodule.external_libraries/portaudio_sc_org.branch "${_pkg}"
+ git config submodule.external_libraries/portaudio_sc_org.branch "${_name}"
git config submodule.external_libraries/yaml-cpp.url "${srcdir}/yaml-cpp"
git submodule update
+ patch -Np1 -i ../boost-1.67.patch
+ mkdir -p build
}
build() {
- cd ${srcdir}/${_pkg}
+ cd "${_name}/build"
_carch=$(uname -m)
- Qt5LinguistTools_DIR="/usr/lib/cmake/Qt5LinguistTools"
- [ -d bld ] || mkdir bld && cd bld
- export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
- msg "$_carch architecture detected."
+# Qt5LinguistTools_DIR="/usr/lib/cmake/Qt5LinguistTools"
+# export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
+ echo "$_carch architecture detected."
case "$_carch" in
"armv6l")
export CC="gcc"
@@ -77,7 +75,6 @@ build() {
-DSC_EL=ON \
-DCMAKE_C_FLAGS="-march=armv6 -mfpu=vfp -mfloat-abi=hard" \
-DCMAKE_CXX_FLAGS="-march=armv6 -mfpu=vfp -mfloat-abi=hard"
- make
;;
"armv7l")
export CC="gcc"
@@ -98,19 +95,24 @@ build() {
-DSC_EL=ON \
-DCMAKE_C_FLAGS="-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon" \
-DCMAKE_CXX_FLAGS="-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon"
- make
;;
*)
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DSC_VIM=OFF \
- -DCMAKE_BUILD_TYPE=Release
- make
+ -DLIBSCSYNTH=ON \
+ -DFORTIFY=ON \
+ -DSC_VIM=OFF \
+ -DSYSTEM_BOOST=ON \
+ -DSYSTEM_YAMLCPP=ON \
+ -DCMAKE_BUILD_TYPE=Release
;;
esac
+ make
}
package() {
- cd "${srcdir}/${_pkg}/bld"
+ cd "${_name}/build"
make DESTDIR="${pkgdir}/" install
+ install -t "${pkgdir}/usr/share/doc/${pkgname}/" \
+ -vDm 644 ../{AUTHORS,{CHANGELOG,README,README_LINUX}.md}
}
diff --git a/boost-1.67.patch b/boost-1.67.patch
new file mode 100644
index 000000000000..1d1abaf91f6e
--- /dev/null
+++ b/boost-1.67.patch
@@ -0,0 +1,12 @@
+diff -upr supercollider-3.9.3.orig/server/supernova/utilities/time_tag.hpp supercollider-3.9.3/server/supernova/utilities/time_tag.hpp
+--- supercollider-3.9.3.orig/server/supernova/utilities/time_tag.hpp 2018-03-28 23:05:07.000000000 +0300
++++ supercollider-3.9.3/server/supernova/utilities/time_tag.hpp 2018-06-03 01:32:16.824417338 +0300
+@@ -230,7 +230,7 @@ public:
+ #ifdef BOOST_DATE_TIME_POSIX_TIME_STD_CONFIG
+ time_duration offset = seconds(get_secs() - ntp_offset) + nanoseconds(get_nanoseconds());
+ #else
+- time_duration offset = seconds(get_secs() - ntp_offset) + microseconds(get_nanoseconds()/1000);
++ time_duration offset = seconds(get_secs() - ntp_offset) + microseconds(long(get_nanoseconds()/1000));
+ #endif
+ return ptime(base, offset);
+ }