summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorØystein Sture2023-12-22 13:02:50 +0100
committerØystein Sture2023-12-22 13:02:50 +0100
commitad3c3c8fb0027f98e7c9498757c192d7ef5600b8 (patch)
tree7d537c77a06b042ac71faa423915172d1d545e8d
parente9848d121606790c7ebc3653fbd69dd5d327463e (diff)
downloadaur-ad3c3c8fb0027f98e7c9498757c192d7ef5600b8.tar.gz
Use PEP 517 based installation
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d54713f6bd4..87cc9a1146c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = python-paramz
pkgdesc = Parameterization Framework for parameterized model creation and handling
pkgver = 0.9.5
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/sods/paramz
arch = any
license = BSD
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-numpy
depends = python-scipy
diff --git a/PKGBUILD b/PKGBUILD
index cfcd18bb59ef..bb1a8fa86dce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
pkgname=python-paramz
pkgver=0.9.5
-pkgrel=5
+pkgrel=6
pkgdesc="Parameterization Framework for parameterized model creation and handling"
arch=("any")
license=("BSD")
url="https://github.com/sods/paramz"
depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-decorator' 'python-climin-git')
optdepends=('ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook')
-makedepends=()
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("https://github.com/sods/paramz/archive/v${pkgver}.tar.gz")
sha256sums=("817af2566ae4dfdfb7fde54c69ebb52070da2077b25315fc8433bfd9e2e520dd")
build() {
cd "paramz-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "paramz-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-paramz/LICENSE"
}