summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2024-03-16 00:30:10 +0100
committerLone_Wolf2024-03-16 00:30:10 +0100
commitae64860f523a57e2c6d0a9e65ed8af8c82d1ca73 (patch)
tree4067852f728a6b46a3c03bbd37088624e36bf6de
parent3aac1fcb136252ab27e1d291bb2ba9f2c7ce1e0a (diff)
downloadaur-ae64860f523a57e2c6d0a9e65ed8af8c82d1ca73.tar.gz
force FORTIFY_SOURCE=2 in build()
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f715a5d544ee..7171d704bdbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = llvm-minimal-git
- pkgver = 19.0.0_r490673.1901f442ca63
- pkgrel = 2
+ pkgver = 19.0.0_r492907.047b2b241def
+ pkgrel = 1
url = https://llvm.org/
arch = x86_64
license = custom:Apache 2.0 with LLVM Exception
@@ -20,7 +20,7 @@ pkgbase = llvm-minimal-git
pkgname = llvm-minimal-git
pkgdesc = Collection of modular and reusable compiler and toolchain technologies
- depends = llvm-libs-minimal-git=19.0.0_r490673.1901f442ca63-2
+ depends = llvm-libs-minimal-git=19.0.0_r492907.047b2b241def-1
optdepends = python: for using lit (LLVM Integrated Tester)
optdepends = python-setuptools: for using lit
provides = llvm
@@ -53,14 +53,14 @@ pkgname = clang-minimal-git
pkgname = clang-libs-minimal-git
pkgdesc = clang runtime libraries, trunk version
- depends = llvm-libs-minimal-git=19.0.0_r490673.1901f442ca63-2
+ depends = llvm-libs-minimal-git=19.0.0_r492907.047b2b241def-1
provides = clang-libs
- conflicts = clang<19.0.0_r490673.1901f442ca63-2
+ conflicts = clang<19.0.0_r492907.047b2b241def-1
conflicts = clang-libs
pkgname = clang-opencl-headers-minimal-git
pkgdesc = clang headers & include files for OpenCL, trunk version
- depends = clang-libs-minimal-git=19.0.0_r490673.1901f442ca63-2
+ depends = clang-libs-minimal-git=19.0.0_r492907.047b2b241def-1
provides = clang-opencl-headers
- conflicts = clang<19.0.0_r490673.1901f442ca63-2
+ conflicts = clang<19.0.0_r492907.047b2b241def-1
conflicts = clang-opencl-headers
diff --git a/PKGBUILD b/PKGBUILD
index 887e5f4c04aa..cd8e1cba6352 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,8 @@
pkgbase=llvm-minimal-git
pkgname=(llvm-minimal-git llvm-libs-minimal-git clang-minimal-git clang-libs-minimal-git clang-opencl-headers-minimal-git)
-pkgver=19.0.0_r490673.1901f442ca63
-pkgrel=2
+pkgver=19.0.0_r492907.047b2b241def
+pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
@@ -87,8 +87,8 @@ done
pkgver() {
- cd llvm-project/llvm
-
+ cd llvm-project/cmake/Modules
+
# This will almost match the output of `llvm-config --version` when the
# LLVM_APPEND_VC_REV cmake flag is turned on. The only difference is
# dash being replaced with underscore because of Pacman requirements.
@@ -132,8 +132,9 @@ build() {
-D LLVM_ENABLE_DUMP=ON
-D LLVM_LIT_ARGS="$LITFLAGS"" -sv --ignore-fail"
)
-
-
+ # build aborts with FORTIFY_SOURCE=3
+ export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+
cmake -B _build -S "$srcdir"/llvm-project/llvm "${cmake_args[@]}" -Wno-dev
pushd "$srcdir"/_build
@@ -143,6 +144,7 @@ build() {
cmake_args+=(-D LLVM_DISTRIBUTION_COMPONENTS="$distribution_components")
cmake -B _build -S "$srcdir"/llvm-project/llvm "${cmake_args[@]}" -Wno-dev
+
make -C _build
}