summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElMastro2022-03-11 23:11:44 +0000
committerElMastro2022-03-11 23:11:44 +0000
commitb057d638e51c0954854c15996c2bcd83fd8039be (patch)
tree44ef64fd297f7412f845ca691fa5865ebe316b70
parentc9fab773895ab52bd1c019e7ec4c55da5b950ec1 (diff)
downloadaur-b057d638e51c0954854c15996c2bcd83fd8039be.tar.gz
Fixed problem with jre7-openjdk, fixed folder of destination of OMSens
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD13
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f5064f7b633..d127d2bb143b 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openmodelica-git
pkgdesc = The Open Source Modelica Suite
- pkgver = 1.16.0.dev.r590.g8f5710f752
- pkgrel = 2
+ pkgver = 1.19.0.dev.r669.gc94e2ebbd9
+ pkgrel = 1
url = https://openmodelica.org
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = openmodelica-git
makedepends = boost
makedepends = clang
makedepends = cmake
- makedepends = jre7-openjdk
+ makedepends = jre-openjdk
makedepends = antlr4-runtime
makedepends = expat
makedepends = ncurses
@@ -24,6 +24,7 @@ pkgbase = openmodelica-git
depends = qt5-svg
depends = qt5-tools
optdepends = zip: requested when exporting to FMU
+ optdepends = sundials: adds more numerical solvers to the simulation runtime
provides = openmodelica
conflicts = openmodelica
conflicts = openmodelica-svn
diff --git a/PKGBUILD b/PKGBUILD
index d25461b53c5b..bf2f7059e325 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Xwang <xwaang1976@gmail.com>
pkgname=openmodelica-git
-pkgver=1.16.0.dev.r590.g8f5710f752
-pkgrel=2
+pkgver=1.19.0.dev.r669.gc94e2ebbd9
+pkgrel=1
pkgdesc="The Open Source Modelica Suite"
arch=('i686' 'x86_64')
url="https://openmodelica.org"
@@ -31,8 +31,9 @@ md5sums=('SKIP'
depends=('java-environment' 'lapack' #'lpsolve' 'openscenegraph' 'python' 'ruby' 'suitesparse'
'boost-libs' 'qt5-webkit' 'qt5-xmlpatterns' 'qt5-svg' 'qt5-tools' # 'fmilib'
)
-makedepends=('git' 'gcc-fortran' 'boost' 'clang' 'cmake' 'jre7-openjdk' 'antlr4-runtime' 'expat' 'ncurses' 'readline')
-optdepends=('zip: requested when exporting to FMU')
+makedepends=('git' 'gcc-fortran' 'boost' 'clang' 'cmake' 'jre-openjdk' 'antlr4-runtime' 'expat' 'ncurses' 'readline')
+optdepends=('zip: requested when exporting to FMU'
+ 'sundials: adds more numerical solvers to the simulation runtime')
provides=('openmodelica')
conflicts=('openmodelica' 'openmodelica-svn' 'openmodelica-dev')
@@ -82,7 +83,7 @@ build() {
autoreconf -fi
autoconf
export CPPFLAGS="$CPPFLAGS -DH5_USE_18_API"
- ./configure --prefix=/usr/ CC=clang CXX=clang++ --with-UMFPACK
+ ./configure --prefix=/usr/ CC=clang --with-UMFPACK # CXX=clang++
make
}
@@ -97,5 +98,5 @@ package() {
install -D -m644 "OMPlot/OMPlot/OMPlotGUI/Resources/icons/omplot.ico" "${pkgdir}/usr/share/openmodelica/icons/omplot.ico"
install -D -m644 "OMCompiler/COPYING" "${pkgdir}/usr/share/licenses/openmodelica/LICENSE"
mkdir "$pkgdir"/usr/OMSens/
- cp -r "OMSens" "$pkgdir/usr/" #Copy OMSens' modules in the working directory
+ cp -r "OMSens" "$pkgdir/usr/share/OMSens" #Copy OMSens' modules in the working directory
}