aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarsha Kuchampudi2019-03-15 18:17:04 -0400
committerHarsha Kuchampudi2019-03-15 18:17:04 -0400
commitb0da36577545af3998eec3f59136c18e084b55d9 (patch)
treef2e31beddac56d0f11190d11bb8c1930a95d924a
parente8c167f8a4706299cd3b20e847a8d89b8675f26b (diff)
downloadaur-b0da36577545af3998eec3f59136c18e084b55d9.tar.gz
No new features. Better compliance with Arch Linux PKGBUILD standards
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD64
-rw-r--r--windscribe-cli.install1
-rw-r--r--windscribe.service15
4 files changed, 48 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc6ce28f91d2..49cbf252e77d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = windscribe-cli
pkgdesc = Port of Windscribe's command line interface
- pkgver = 1.3
- pkgrel = 19
+ pkgver = 1.3_19
+ pkgrel = 1
url = https://windscribe.com/
install = windscribe-cli.install
arch = x86_64
arch = i686
arch = armv6h
- license = GPL-2+
+ license = GPL
depends = openvpn
optdepends = stunnel
- replaces = windscribe-cli
- source_x86_64 = windscribe-cli_1.3_19.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.3-19_amd64.deb
+ source = windscribe.service
+ sha256sums = 5be3a28e3b49a233b68ac4638bc5407e1fde043de5bfaddff00d0031947a6d06
+ source_x86_64 = windscribe-cli_1.3_19_1.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.3-19_amd64.deb
sha256sums_x86_64 = 2adef3ff36423de681279a7f8ddaac29612779bdbcba9cf24098952646fa0253
- source_i686 = windscribe-cli_1.3_19.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.3-19_i386.deb
+ source_i686 = windscribe-cli_1.3_19_1.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.3-19_i386.deb
sha256sums_i686 = 141d9d229cd94de6d5212f909840682f5bf2d85f0de91407cf7fec28ff79161f
- source_armv6h = windscribe-cli_1.3_19.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.3-19_armhf.deb
+ source_armv6h = windscribe-cli_1.3_19_1.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_1.3-19_armhf.deb
sha256sums_armv6h = af8938c03355c7523f3abbe2090cbc43b7f782c3f1caf90c19b91b03173dd524
pkgname = windscribe-cli
diff --git a/PKGBUILD b/PKGBUILD
index 174e2cc37a32..88ebb93512cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
##########################################################################
# Maintainer: Harsha Kuchampudi <harshakuchampudi AT gmail DOT com>
# Github: https://github.com/hkuchampudi/Windscribe
-# Updated: 2018-10-03
+# Updated: 2019-03-09
##########################################################################
pkgname=windscribe-cli
-pkgver=1.3
-pkgrel=19
+pkgver=1.3_19
+pkgrel=1
pkgdesc="Port of Windscribe's command line interface"
arch=('x86_64' 'i686' 'armv6h')
url="https://windscribe.com/"
-license=('GPL-2+')
+license=('GPL')
depends=('openvpn')
optdepends=('stunnel')
-replaces=('windscribe-cli')
install="windscribe-cli.install"
-source_armv6h=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}-${pkgrel}_armhf.deb")
-source_i686=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}-${pkgrel}_i386.deb")
-source_x86_64=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver}-${pkgrel}_amd64.deb")
+
+# Platform specific binaries
+source_armv6h=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver//_/-}_armhf.deb")
+source_i686=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver//_/-}_i386.deb")
+source_x86_64=("${pkgname}_${pkgver}_${pkgrel}.deb::https://assets.staticnetcontent.com/desktop/linux/windscribe-cli_${pkgver//_/-}_amd64.deb")
+
+# Common files
+source=('windscribe.service')
+
+# Checksums
sha256sums_armv6h=('af8938c03355c7523f3abbe2090cbc43b7f782c3f1caf90c19b91b03173dd524')
sha256sums_i686=('141d9d229cd94de6d5212f909840682f5bf2d85f0de91407cf7fec28ff79161f')
sha256sums_x86_64=('2adef3ff36423de681279a7f8ddaac29612779bdbcba9cf24098952646fa0253')
+sha256sums=('5be3a28e3b49a233b68ac4638bc5407e1fde043de5bfaddff00d0031947a6d06')
package() {
# Extract the debian package
@@ -31,43 +38,20 @@ package() {
tar xf "data.tar.xz" -C "${srcdir}/data"
tar xf "control.tar.gz" -C "${srcdir}/control"
- # Create systemd service
- echo "Creating systemd service"
- mkdir -p $srcdir/data/etc/systemd/system
- echo "
- [Unit]
- Description=Windscribe VPN CLI Service
- After=syslog.target network.target remote-fs.target nss-lookup.target
-
- [Service]
- Type=simple
- ExecStart=/usr/bin/windscribe start
- ExecStop=/usr/bin/windscribe stop
- Restart=on-failure
- KillMode=control-group
- SuccessExitStatus=SIGKILL
- PIDFile=/etc/windscribe/windscribe.pid
-
- [Install]
- WantedBy=multi-user.target
- " >> $srcdir/data/etc/systemd/system/windscribe.service
-
# Configure bash completion
echo "Configuring bash completion"
- mkdir $pkgdir/etc
- cp -r "${srcdir}/data/etc/bash_completion.d" "${pkgdir}/etc/"
+ install -Dm644 "${srcdir}/data/etc/bash_completion.d/windscribe_complete" -t "${pkgdir}/etc/bash_completion.d/"
+
# Make windscribe directory
echo "Creating windscribe directory"
mkdir $pkgdir/etc/windscribe
+
# Configure systemd service
echo "Configuring systemd service"
- mkdir -p $pkgdir/etc/systemd/system/
- cp "${srcdir}/data/etc/systemd/system/windscribe.service" "${pkgdir}/etc/systemd/system/"
- chmod 0664 "${pkgdir}/etc/systemd/system/windscribe.service"
- # Configure windscribe binary and docs
- echo "Configuring binary and docs"
- mkdir -p $pkgdir/usr/bin
- cp -r "${srcdir}/data/usr/" "${pkgdir}/"
- chmod 0755 "${pkgdir}/usr/bin/windscribe"
- chmod 0755 -R "${pkgdir}/usr/share/doc/windscribe-cli"
+ install -Dm644 "windscribe.service" -t "${pkgdir}/usr/lib/systemd/system/"
+
+ # Configure windscribe binary and license
+ echo "Configuring binary and license"
+ install -Dm755 "${srcdir}/data/usr/bin/windscribe" -t "${pkgdir}/usr/bin/"
+ install -Dm644 "${srcdir}/data/usr/share/doc/windscribe-cli/copyright" "${pkgdir}/usr/share/licenses/windscribe-cli/LICENSE"
}
diff --git a/windscribe-cli.install b/windscribe-cli.install
index 86194bf60fc8..bc9a6d426eda 100644
--- a/windscribe-cli.install
+++ b/windscribe-cli.install
@@ -16,6 +16,7 @@ pre_remove() {
post_remove() {
rm -rf /etc/windscribe
rm -rf /usr/share/doc/windscribe-cli
+ rm -rf /usr/share/licenses/windscribe-cli
rm -rf /etc/bash_completion.d/windscribe_complete
rm -rf /var/log/windscribe
systemctl daemon-reload
diff --git a/windscribe.service b/windscribe.service
new file mode 100644
index 000000000000..ee4c1d30aef3
--- /dev/null
+++ b/windscribe.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Windscribe VPN CLI Service
+After=syslog.target network.target remote-fs.target nss-lookup.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/windscribe start
+ExecStop=/usr/bin/windscribe stop
+Restart=on-failure
+KillMode=control-group
+SuccessExitStatus=SIGKILL
+PIDFile=/etc/windscribe/windscribe.pid
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file