summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera Micó2023-07-09 21:30:21 +0000
committerJoan Bruguera Micó2023-07-09 21:31:21 +0000
commitb0e8d2562563e00a133de1663af7a37948a3eddd (patch)
tree27ee6cdb0498af7ac93ff110f23ea49b033316c6
parent3546e1b8705ab8eeed4d13f78ae78ff00d1d10cd (diff)
downloadaur-b0e8d2562563e00a133de1663af7a37948a3eddd.tar.gz
Add patches for Linux 6.5 support.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eeddb05e4b21..1dad31be779b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cryptodev-linux
pkgdesc = Kernel module providing access to Linux kernel cryptographic drivers from userspace
pkgver = 1.13
- pkgrel = 1
+ pkgrel = 2
url = http://cryptodev-linux.org/
arch = i686
arch = x86_64
@@ -14,6 +14,12 @@ pkgbase = cryptodev-linux
provides = cryptodev_friendly
conflicts = cryptodev_friendly
source = https://github.com/cryptodev-linux/cryptodev-linux/archive/cryptodev-linux-1.13.tar.gz
+ source = 0001-linux-6.5.patch::https://github.com/cryptodev-linux/cryptodev-linux/commit/592017c3a910a3905b1925aee88c4674e9a596b7.patch?full_index=1
+ source = 0002-linux-6.5.patch::https://github.com/cryptodev-linux/cryptodev-linux/commit/99ae2a39ddc3f89c66d9f09783b591c0f2dbf2e9.patch?full_index=1
+ source = 0003-linux-6.5.patch::https://github.com/cryptodev-linux/cryptodev-linux/commit/bb8bc7cf60d2c0b097c8b3b0e807f805b577a53f.patch?full_index=1
sha256sums = 33b7915c46eb39a37110e88c681423c0dd0df25d784b6e1475ac3196367f0db5
+ sha256sums = d8fd96d4e3c2a0a2e89155a552f5a909e9fbfb6275e01013d59fe74390f68355
+ sha256sums = 8af6ef9a28f0c13f3246fa76ca05993cf2b193eacb9d6b9dbae92e40cef92dae
+ sha256sums = c4a3ef3473dbb8cadd1a2815473d16b139c007bbc6054c4a9ede89fd6a4766f2
pkgname = cryptodev-linux
diff --git a/PKGBUILD b/PKGBUILD
index 5682e623d795..c8b71b1189a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=cryptodev-linux
pkgname=cryptodev-linux
pkgdesc="Kernel module providing access to Linux kernel cryptographic drivers from userspace"
pkgver=1.13
-pkgrel=1
+pkgrel=2
url='http://cryptodev-linux.org/'
license=("GPL")
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -17,6 +17,20 @@ optdepends=('openssl-cryptodev: OpenSSL with cryptodev support')
source=("https://github.com/${pkgbase}/${pkgbase}/archive/${pkgbase}-${pkgver}.tar.gz")
sha256sums=('33b7915c46eb39a37110e88c681423c0dd0df25d784b6e1475ac3196367f0db5')
+# Linux 6.5 support
+source+=("0001-linux-6.5.patch::https://github.com/cryptodev-linux/cryptodev-linux/commit/592017c3a910a3905b1925aee88c4674e9a596b7.patch?full_index=1"
+ "0002-linux-6.5.patch::https://github.com/cryptodev-linux/cryptodev-linux/commit/99ae2a39ddc3f89c66d9f09783b591c0f2dbf2e9.patch?full_index=1"
+ "0003-linux-6.5.patch::https://github.com/cryptodev-linux/cryptodev-linux/commit/bb8bc7cf60d2c0b097c8b3b0e807f805b577a53f.patch?full_index=1")
+sha256sums+=('d8fd96d4e3c2a0a2e89155a552f5a909e9fbfb6275e01013d59fe74390f68355'
+ '8af6ef9a28f0c13f3246fa76ca05993cf2b193eacb9d6b9dbae92e40cef92dae'
+ 'c4a3ef3473dbb8cadd1a2815473d16b139c007bbc6054c4a9ede89fd6a4766f2')
+prepare() {
+ cd "${srcdir}/${pkgbase}-${pkgbase}-${pkgver}"
+ patch -Np1 -i ../0001-linux-6.5.patch
+ patch -Np1 -i ../0002-linux-6.5.patch
+ patch -Np1 -i ../0003-linux-6.5.patch
+}
+
build() {
cd "${srcdir}/${pkgbase}-${pkgbase}-${pkgver}"
make KERNEL_DIR=/usr/src/linux