summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEkin Dursun2019-11-18 00:00:00 +0300
committerEkin Dursun2019-11-18 00:00:00 +0300
commitb1c528ed43a111c521a6c113a8c5159b1320afd5 (patch)
tree4086e8c36db2625b54954fa9e37785affc801a4a
parentcbd51ae7fbb0c9e3a54573cb40bb34a5bf7543bb (diff)
downloadaur-b1c528ed43a111c521a6c113a8c5159b1320afd5.tar.gz
Version bump
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD8
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d2512ef9eb2..cb5fad4f68b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = python-uncompyle6
pkgdesc = Python byte-code disassembler and source-code converter.
- pkgver = 3.2.6
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/rocky/python-uncompyle6/
arch = any
license = MIT
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/u/uncompyle6/uncompyle6-3.2.6.tar.gz
- sha256sums = 3a40f4f4b8b02a8687bd98c598980bed38a4770e3de253847eafed4b7167d07f
+ source = https://files.pythonhosted.org/packages/source/u/uncompyle6/uncompyle6-3.5.0.tar.gz
+ sha256sums = 4e6e86c05de588cbf5a2c35ddd080f23cd1770a1ad15c84dc1b2c78d65113af7
pkgname = python-uncompyle6
- depends = python-spark-parser>=1.8.7
+ depends = python-spark-parser>=1.8.9
depends = python-spark-parser<1.9.0
- depends = python-xdis>=3.9.0
- depends = python-xdis<3.10.0
+ depends = python-xdis>=4.1.2
+ depends = python-xdis<4.2.0
pkgname = python2-uncompyle6
- depends = python2-spark-parser>=1.8.7
+ depends = python2-spark-parser>=1.8.9
depends = python2-spark-parser<1.9.0
- depends = python2-xdis>=3.9.0
- depends = python2-xdis<3.10.0
+ depends = python2-xdis>=4.1.2
+ depends = python2-xdis<4.2.0
diff --git a/PKGBUILD b/PKGBUILD
index 2d4d06f1b5e8..bd3bd5d5b8d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=uncompyle6
pkgbase="python-${_name}"
pkgname=("python-${_name}" "python2-${_name}")
-pkgver=3.2.6
+pkgver=3.5.0
pkgrel=1
pkgdesc="Python byte-code disassembler and source-code converter."
arch=('any')
@@ -12,17 +12,17 @@ url="https://github.com/rocky/python-uncompyle6/"
license=('MIT')
makedepends=('python-setuptools' 'python2-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('3a40f4f4b8b02a8687bd98c598980bed38a4770e3de253847eafed4b7167d07f')
+sha256sums=('4e6e86c05de588cbf5a2c35ddd080f23cd1770a1ad15c84dc1b2c78d65113af7')
package_python-uncompyle6() {
- depends=('python-spark-parser>=1.8.7' 'python-spark-parser<1.9.0' 'python-xdis>=3.9.0' 'python-xdis<3.10.0')
+ depends=('python-spark-parser>=1.8.9' 'python-spark-parser<1.9.0' 'python-xdis>=4.1.2' 'python-xdis<4.2.0')
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}
package_python2-uncompyle6() {
- depends=('python2-spark-parser>=1.8.7' 'python2-spark-parser<1.9.0' 'python2-xdis>=3.9.0' 'python2-xdis<3.10.0')
+ depends=('python2-spark-parser>=1.8.9' 'python2-spark-parser<1.9.0' 'python2-xdis>=4.1.2' 'python2-xdis<4.2.0')
cd "$srcdir/$_name-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1