summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2021-04-23 23:53:08 +0100
committerGraham Edgecombe2021-04-23 23:54:11 +0100
commitb1c5bf9438e136e482da0e7419d06b205a8a41aa (patch)
tree5c208c95c3a18d8864afcfc46cab78471c03a486
parent86772e4860e6e5d0239db244e55b3bd9bfa64fbb (diff)
downloadaur-b1c5bf9438e136e482da0e7419d06b205a8a41aa.tar.gz
Use discord-rpc-api
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 6 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21050ce939c5..81f3b4bba299 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openrct2-git
pkgdesc = Open source re-implementation of Roller Coaster Tycoon 2 (requires full copy of the game)
- pkgver = r19968.0ae86d055
+ pkgver = r21143.594b08c91
pkgrel = 1
url = https://openrct2.io
install = openrct2.install
@@ -11,7 +11,7 @@ pkgbase = openrct2-git
license = GPL3
makedepends = git
makedepends = cmake
- makedepends = rapidjson
+ makedepends = discord-rpc-api
depends = hicolor-icon-theme
depends = sdl2
depends = curl
@@ -31,8 +31,6 @@ pkgbase = openrct2-git
provides = openrct2
conflicts = openrct2
source = openrct2-git::git+https://github.com/OpenRCT2/OpenRCT2.git#branch=develop
- source = discord-rpc::git+https://github.com/discordapp/discord-rpc.git
- sha256sums = SKIP
sha256sums = SKIP
pkgname = openrct2-git
diff --git a/PKGBUILD b/PKGBUILD
index b1df188fb064..4ec7047196a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Graham Edgecombe <graham@grahamedgecombe.com>
pkgname=openrct2-git
-pkgver=r19968.0ae86d055
+pkgver=r21143.594b08c91
pkgrel=1
pkgdesc='Open source re-implementation of Roller Coaster Tycoon 2 (requires full
copy of the game)'
@@ -9,7 +9,7 @@ url='https://openrct2.io'
license=('GPL3')
depends=('hicolor-icon-theme' 'sdl2' 'curl' 'nlohmann-json' 'speexdsp'
'fontconfig' 'libpng' 'openssl' 'libzip' 'icu' 'duktape' 'benchmark')
-makedepends=('git' 'cmake' 'rapidjson')
+makedepends=('git' 'cmake' 'discord-rpc-api')
optdepends=('zenity: System dialog box support (GNOME/GTK)'
'kdialog: System dialog box support (KDE)'
'alsa-lib: ALSA audio driver'
@@ -17,24 +17,14 @@ optdepends=('zenity: System dialog box support (GNOME/GTK)'
conflicts=('openrct2')
provides=('openrct2')
install=openrct2.install
-source=("$pkgname"::'git+https://github.com/OpenRCT2/OpenRCT2.git#branch=develop'
- 'discord-rpc::git+https://github.com/discordapp/discord-rpc.git')
-sha256sums=('SKIP'
- 'SKIP')
+source=("$pkgname"::'git+https://github.com/OpenRCT2/OpenRCT2.git#branch=develop')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/$pkgname"
- ln -sf "$srcdir/discord-rpc"
-
- mkdir -p discord-rpc/thirdparty
- ln -sf "/usr/include/rapidjson" discord-rpc/thirdparty
-}
-
build() {
cd "$srcdir/$pkgname"
@@ -51,10 +41,5 @@ package() {
make DESTDIR="$pkgdir" install
rm "$pkgdir/usr/lib/libopenrct2.a"
- rm "$pkgdir/usr/lib/libdiscord-rpc.a"
rmdir "$pkgdir/usr/lib"
-
- rm "$pkgdir/usr/include/discord_rpc.h"
- rm "$pkgdir/usr/include/discord_register.h"
- rmdir "$pkgdir/usr/include"
}