summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2024-04-03 00:16:14 +0200
committermrxx2024-04-03 00:16:14 +0200
commitb2c633e2431cd49fb4b9b6d4d332dd40b46aac6f (patch)
tree387fee1b780b1b99c9ad21f04c44b5a471b70af5
parente892f7b2080fc337e4ea8b7cc91a255994e8fb2d (diff)
downloadaur-b2c633e2431cd49fb4b9b6d4d332dd40b46aac6f.tar.gz
Fix taglib 2.0 regressions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--taglib.patch46
3 files changed, 55 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05902c113b20..fdf172b08071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = musique
pkgdesc = A finely crafted music player
pkgver = 1.12
- pkgrel = 1
+ pkgrel = 2
url = https://flavio.tordini.org/musique
arch = x86_64
license = GPL3
@@ -18,6 +18,8 @@ pkgbase = musique
source = git+https://github.com/flaviotordini/updater.git
source = git+https://github.com/flaviotordini/js.git
source = git+https://github.com/flaviotordini/sharedcache.git
+ source = taglib.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 98a831b0cf0b..82899fa45e90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=musique
pkgver=1.12
-pkgrel=1
+pkgrel=2
pkgdesc='A finely crafted music player'
arch=('x86_64')
url='https://flavio.tordini.org/musique'
@@ -23,13 +23,15 @@ source=("git+${_giturl}/musique.git#tag=${pkgver}"
"git+${_giturl}/media.git"
"git+${_giturl}/updater.git"
"git+${_giturl}/js.git"
- "git+${_giturl}/sharedcache.git")
+ "git+${_giturl}/sharedcache.git"
+ "taglib.patch")
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -42,6 +44,8 @@ prepare() {
git config submodule.lib/js.url "$srcdir/js"
git config submodule.lib/sharedcache.url "$srcdir/sharedcache"
git -c protocol.file.allow=always submodule update
+
+ patch -p2 <$srcdir/taglib.patch
}
build() {
diff --git a/taglib.patch b/taglib.patch
new file mode 100644
index 000000000000..9aa2913b8daf
--- /dev/null
+++ b/taglib.patch
@@ -0,0 +1,46 @@
+diff -rupw A/musique/src/coverutils.cpp B/musique/src/coverutils.cpp
+--- A/musique/src/coverutils.cpp 2024-04-02 22:43:34.330011875 +0200
++++ B/musique/src/coverutils.cpp 2024-04-02 23:56:42.855952202 +0200
+@@ -158,8 +158,8 @@ bool CoverUtils::coverFromMP4(const QStr
+ TagLib::MP4::Tag *tag = static_cast<TagLib::MP4::Tag *>(f.tag());
+ if (!tag) return false;
+
+- TagLib::MP4::ItemListMap itemsListMap = tag->itemListMap();
+- TagLib::MP4::Item coverItem = itemsListMap["covr"];
++ TagLib::MP4::ItemMap itemsMap = tag->itemMap();
++ TagLib::MP4::Item coverItem = itemsMap["covr"];
+ TagLib::MP4::CoverArtList coverArtList = coverItem.toCoverArtList();
+ TagLib::MP4::CoverArt coverArt = coverArtList.front();
+
+diff -rupw A/musique/src/mainwindow.cpp B/musique/src/mainwindow.cpp
+--- A/musique/src/mainwindow.cpp 2024-04-02 22:43:34.333345149 +0200
++++ B/musique/src/mainwindow.cpp 2024-04-02 23:48:04.371738064 +0200
+@@ -90,6 +90,7 @@ $END_LICENSE */
+ #include "updater.h"
+ #endif
+
++#include <iostream>
+
+ namespace {
+ MainWindow *singleton = nullptr;
+diff -rupw A/musique/src/tags/mp4utils.h B/musique/src/tags/mp4utils.h
+--- A/musique/src/tags/mp4utils.h 2024-04-02 22:43:34.333345149 +0200
++++ B/musique/src/tags/mp4utils.h 2024-04-02 23:51:39.551287361 +0200
+@@ -9,7 +9,7 @@
+ namespace Mp4Utils {
+
+ void load(TagLib::MP4::Tag *tag, Tags *tags) {
+- const TagLib::MP4::ItemListMap &map = tag->itemListMap();
++ const TagLib::MP4::ItemMap &map = tag->itemMap();
+
+ if (map.contains("trkn")) {
+ TagLib::MP4::Item::IntPair intPair = map["trkn"].toIntPair();
+@@ -31,7 +31,7 @@ void load(TagLib::MP4::Tag *tag, Tags *t
+ tags->setComposerSort(v);
+ }
+
+- TagLib::MP4::ItemListMap::ConstIterator it = map.find("aART");
++ TagLib::MP4::ItemMap::ConstIterator it = map.find("aART");
+ if (it != map.end()) {
+ TagLib::StringList sl = it->second.toStringList();
+ if (!sl.isEmpty())