summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Fischer2018-04-04 15:50:14 +0200
committerAaron Fischer2018-04-04 15:50:14 +0200
commitb4b7e9983996fd7d1c7cabea3979db7b91e0b3e6 (patch)
tree62ee60e3456789f583291092655935e80d413db7
parente1f34e443c4801859d7e98fc5236c4dda187d5fb (diff)
downloadaur-b4b7e9983996fd7d1c7cabea3979db7b91e0b3e6.tar.gz
Bump to 0.19.0 (fixes the isl mess)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e578c3d0b71..b0f642a3fd8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = cloog
pkgdesc = Library that generates loops for scanning polyhedra
- pkgver = 0.18.5
- pkgrel = 5
+ pkgver = 0.19.0
+ pkgrel = 1
url = http://www.bastoul.net/cloog/
arch = i686
arch = x86_64
arch = armv7h
license = GPL
depends = osl
- provides = isl=0.18
- conflicts = isl
- source = https://github.com/periscop/cloog/releases/download/cloog-0.18.5/cloog-0.18.5.tar.gz
- sha256sums = 48602a72aaec8e1dabc33ec0622739d3ad585b7f0ec480eebdc1d724822b7cfd
+ depends = isl
+ source = https://github.com/periscop/cloog/releases/download/cloog-0.19.0/cloog-0.19.0.tar.gz
+ sha512sums = a0646f31e7a2c1809c51b812f58dc3f733f3a7c4cdf84fa5fee4ed7a372b7bf649561c7eceb7bfc754f1aca519ec0fc3718e08775e7eb072a238ce341edda10a
pkgname = cloog
diff --git a/PKGBUILD b/PKGBUILD
index d126014a9720..d92bf382f1f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,19 @@
# Contributor: Allan McRae <allan@archlinux.org>
pkgname=cloog
-pkgver=0.18.5
-pkgrel=5
+pkgver=0.19.0
+pkgrel=1
pkgdesc="Library that generates loops for scanning polyhedra"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.bastoul.net/cloog/"
license=('GPL')
-
-depends=('osl')
-
-# cloog is not compatible with isl 0.19, so we use the bundled
-# version of isl, see https://github.com/periscop/cloog/issues/37
-provides=('isl=0.18')
-conflicts=('isl')
-
+depends=('osl' 'isl')
source=(https://github.com/periscop/cloog/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('48602a72aaec8e1dabc33ec0622739d3ad585b7f0ec480eebdc1d724822b7cfd')
+sha512sums=('a0646f31e7a2c1809c51b812f58dc3f733f3a7c4cdf84fa5fee4ed7a372b7bf649561c7eceb7bfc754f1aca519ec0fc3718e08775e7eb072a238ce341edda10a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --with-osl=system --with-isl=bundle
- #./configure --prefix=/usr --with-isl=system --with-osl=system
+ ./configure --prefix=/usr --with-isl=system --with-osl=system
make
}