summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-06-09 12:45:08 +0100
committerCharles Bos2015-06-09 12:45:08 +0100
commitb883208c9753f7febef3803cc2e61261c14ed9c2 (patch)
tree0cb2ec0044b50e0e843c2188a44eb112711269e4
downloadaur-b883208c9753f7febef3803cc2e61261c14ed9c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD66
-rw-r--r--barry.desktop6
-rw-r--r--barry.install16
-rw-r--r--fix-sizeof-use.patch30
-rw-r--r--wx3.0-compat.patch58
6 files changed, 209 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0f8468a04ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by makepkg 4.2.1
+# Sun May 3 10:37:51 UTC 2015
+pkgbase = barry
+ pkgdesc = Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices.
+ pkgver = 0.18.4
+ pkgrel = 4
+ url = http://www.netdirect.ca/software/packages/barry
+ install = barry.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libusbx
+ depends = zlib
+ depends = libglademm
+ depends = libtar
+ depends = libxml++
+ depends = wxgtk
+ depends = sdl
+ depends = libgcal
+ optdepends = fuse: for mounting the BB database with bfuse
+ optdepends = ppp: for tethering with pppob
+ options = !libtool
+ source = http://downloads.sourceforge.net/barry/barry-0.18.4.tar.bz2
+ source = barry.desktop
+ source = fix-sizeof-use.patch
+ source = wx3.0-compat.patch
+ sha256sums = 4036d9eb46a86794455f9f125e8d77dd922e06f74889c5be7f35554be3f48a73
+ sha256sums = cb30b64a392ff5ff0482399cd31e6c997c57e60969145680497a54ffbb8f7d67
+ sha256sums = d1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e
+ sha256sums = d89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3
+
+pkgname = barry
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2034b7c1f6ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Charles Bos <charlesbos1 AT gmail>
+# Contributor: Fritz <V155> Reichwald <fritz.reichwald at gmail.com>
+# Contributor: Hauke Wesselmann <hauke at h-dawg.de>
+
+pkgname=barry
+pkgver=0.18.4
+pkgrel=4
+pkgdesc="Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices."
+url=('http://www.netdirect.ca/software/packages/barry')
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('libusbx' 'zlib' 'libglademm' 'libtar' 'libxml++' 'wxgtk' 'sdl' 'libgcal')
+optdepends=('fuse: for mounting the BB database with bfuse'
+ 'ppp: for tethering with pppob')
+options=('!libtool')
+install=(${pkgname}.install)
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ "${pkgname}.desktop"
+ "fix-sizeof-use.patch"
+ "wx3.0-compat.patch")
+sha256sums=('4036d9eb46a86794455f9f125e8d77dd922e06f74889c5be7f35554be3f48a73'
+ 'cb30b64a392ff5ff0482399cd31e6c997c57e60969145680497a54ffbb8f7d67'
+ 'd1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e'
+ 'd89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # Debian patches
+ patch -Np1 -i "${srcdir}/fix-sizeof-use.patch"
+ patch -Np1 -i "${srcdir}/wx3.0-compat.patch"
+
+ # Disable Werror
+ find /$(pwd) -type f -exec sed -i 's/-Werror//g' '{}' \;
+
+ autoreconf -fi
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr --libexec=/usr/lib --sbindir=/usr/bin \
+ --enable-gui \
+ --enable-desktop \
+ --without-guisu
+
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR=${pkgdir} install
+
+ # Install PPP scripts for pppob
+ mkdir -p ${pkgdir}/etc/ppp/peers/ ${pkgdir}/etc/chatscripts/
+ find ${srcdir}/${pkgname}-${pkgver}/ppp/ -name *.chat -exec cp {} ${pkgdir}/etc/chatscripts/ \;
+ find ${srcdir}/${pkgname}-${pkgver}/ppp/ ! -name *.chat ! -name README -exec cp {} ${pkgdir}/etc/ppp/peers/ \;
+
+ # Install .desktop file and icon
+ mkdir -p ${pkgdir}/usr/share/pixmaps
+ cp ./desktop/images/barry_logo_icon.xpm ${pkgdir}/usr/share/pixmaps
+
+ mkdir -p ${pkgdir}/usr/share/applications
+ cp ../barry.desktop ${pkgdir}/usr/share/applications
+}
diff --git a/barry.desktop b/barry.desktop
new file mode 100644
index 000000000000..cd34c95dd684
--- /dev/null
+++ b/barry.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Barry
+Type=Application
+Exec=barrydesktop
+Icon=barry_logo_icon
+Categories=Application;Utility; \ No newline at end of file
diff --git a/barry.install b/barry.install
new file mode 100644
index 000000000000..e7ca93e53500
--- /dev/null
+++ b/barry.install
@@ -0,0 +1,16 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+op=$1
+shift
+
+$op $*
diff --git a/fix-sizeof-use.patch b/fix-sizeof-use.patch
new file mode 100644
index 000000000000..a3d516e3a338
--- /dev/null
+++ b/fix-sizeof-use.patch
@@ -0,0 +1,30 @@
+Description: Fix sizeof(pointer) to be sizeof(buffer_pointed_to)
+Author: Olly Betts <olly@survex.com>
+Forwarded: no
+Last-Update: 2014-08-14
+
+--- a/src/vformat.c
++++ b/src/vformat.c
+@@ -1881,11 +1881,11 @@
+
+ //static unsigned char _evc_base64_rank[256];
+
+-static void base64_init(char *rank)
++static void base64_init(char *rank, size_t len)
+ {
+ int i;
+
+- memset(rank, 0xff, sizeof(rank));
++ memset(rank, 0xff, len);
+ for (i=0;i<64;i++) {
+ rank[(unsigned int)base64_alphabet[i]] = i;
+ }
+@@ -2011,7 +2011,7 @@
+ static size_t base64_decode_step(const unsigned char *in, size_t len, unsigned char *out, int *state, unsigned int *save)
+ {
+ unsigned char base64_rank[256];
+- base64_init((char*)base64_rank);
++ base64_init((char*)base64_rank, sizeof(base64_rank));
+
+ register const unsigned char *inptr;
+ register unsigned char *outptr;
diff --git a/wx3.0-compat.patch b/wx3.0-compat.patch
new file mode 100644
index 000000000000..72fd2ce2c7f5
--- /dev/null
+++ b/wx3.0-compat.patch
@@ -0,0 +1,58 @@
+Description: Fix to build with wxWidgets 3.0
+Author: Olly Betts <olly@survex.com>
+Last-Update: 2014-08-14
+
+--- a/desktop/src/Mode.h
++++ b/desktop/src/Mode.h
+@@ -23,6 +23,7 @@
+ #define __BARRYDESKTOP_MODE_H__
+
+ #include <wx/wx.h>
++#include <wx/listctrl.h>
+
+ class Mode
+ {
+--- a/desktop/src/bsyncjail.cc
++++ b/desktop/src/bsyncjail.cc
+@@ -177,8 +177,8 @@
+ void BarrySyncJail::HandleConflict(OpenSync::SyncConflict &conflict)
+ {
+ OpenSync::SyncConflict::iterator i;
+- int size = 0;
+- wxChar *buf = 0;
++ size_t size = 0;
++ const wxChar *buf = 0;
+
+ // start with a new sequence ID
+ m_sequenceID++;
+@@ -218,7 +218,7 @@
+ }
+
+ // then wait on the server to tell us what choice was made
+- buf = m_conflict_con->Request(CONFLICT_ITEM_ANSWER, &size);
++ buf = (const wxChar *)m_conflict_con->Request(CONFLICT_ITEM_ANSWER, &size);
+ if( buf ) {
+ wxString msg(buf);
+ istringstream iss(string(msg.utf8_str()));
+--- a/desktop/src/MigrateDlg.cc
++++ b/desktop/src/MigrateDlg.cc
+@@ -81,7 +81,7 @@
+ wxCommandEvent event(MET_PROMPT_PASSWORD, wxID_ANY);
+ event.SetEventObject(m_dlg);
+ event.SetInt(bp.remaining_tries());
+- m_dlg->AddPendingEvent(event);
++ m_dlg->GetEventHandler()->ProcessEvent(event);
+ m_dlg->WaitForEvent();
+
+ password_result = m_dlg->GetPassword().utf8_str();
+--- a/src/probe.cc
++++ b/src/probe.cc
+@@ -170,7 +170,7 @@
+ // now dump all logged error messages
+ if( auto_dump_log && m_fail_msgs.size() ) {
+ eout(string_vprintf(_("Probe logged %u exception messages:"),
+- m_fail_msgs.size()));
++ (unsigned)m_fail_msgs.size()));
+ for( std::vector<std::string>::const_iterator b = m_fail_msgs.begin();
+ b != m_fail_msgs.end();
+ ++b )