summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShizcow2020-07-07 09:21:06 -0600
committerShizcow2020-07-07 09:21:06 -0600
commitb901ab2be05fc071ae053021de8a6123926c33cd (patch)
tree24b54d2c2ead7ae27ca1c850fcba45431b99f8cd
parent7c24bc05fee8ac1610fab89c4287f8cf1c04c130 (diff)
downloadaur-b901ab2be05fc071ae053021de8a6123926c33cd.tar.gz
Upstream release, fixed deps
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09439948b809..31a727f85494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dmenu-rs
pkgdesc = A 1:1 port of dmenu, rewritten in Rust
- pkgver = 5.2.3
- pkgrel = 2
+ pkgver = 5.3.0
+ pkgrel = 1
url = https://github.com/Shizcow/dmenu-rs
arch = i686
arch = x86_64
@@ -9,9 +9,10 @@ pkgbase = dmenu-rs
makedepends = rust
makedepends = git
makedepends = clang
- depends = sh
- depends = libxinerama
depends = libxft
+ depends = xclip
+ depends = aspell
+ depends = libxinerama
provides = dmenu
conflicts = dmenu
source = dmenu-rs::git+https://github.com/Shizcow/dmenu-rs.git
diff --git a/PKGBUILD b/PKGBUILD
index b281dfebfabe..d4898cdd664b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,30 @@
# or run `make plugins` in the cloned repo
PLUGINS=""
+
+# -------------------------------------------------------
+# DEPENDS
+# -------------------------------------------------------
+# If you want a super-minimal system, some of the following
+# dependencies can be disabled
+# Always required:
+depends=('libxft')
+# Required for plugins which copy to clip perminantly
+# this includes: calc, spellcheck
+depends+=('xclip')
+# Requred for the spellcheck plugin
+depends+=('aspell')
+# Required for Xinerama (requires editing config.mk to disable)
+depends+=('libxinerama')
+
_pkgname=dmenu
pkgname=$_pkgname-rs
-pkgver=5.2.3
-pkgrel=2
+pkgver=5.3.0
+pkgrel=1
pkgdesc="A 1:1 port of dmenu, rewritten in Rust"
arch=('i686' 'x86_64')
url="https://github.com/Shizcow/dmenu-rs"
license=('GPL')
-depends=('sh' 'libxinerama' 'libxft')
makedepends=('rust' 'git' 'clang')
provides=($_pkgname)
conflicts=($_pkgname)