summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornotEvil2023-05-10 23:50:21 +0200
committernotEvil2023-05-10 23:51:11 +0200
commitbaa50ee526624ede2f3c79d95a07f6d3a9b22f5d (patch)
tree66e2ac63e0870c7d83fb56e27bb998c09593f587
parent746ff1e467550b9daadc158124983d949e50ea2f (diff)
downloadaur-baa50ee526624ede2f3c79d95a07f6d3a9b22f5d.tar.gz
Updated to version 3.1.1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
-rw-r--r--patch11
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5321c3b0945b..434c8ff1d911 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-bokeh
pkgdesc = Interactive Web Plotting for Python
- pkgver = 3.1.0
+ pkgver = 3.1.1
pkgrel = 1
url = http://bokeh.pydata.org/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 4e29374df738..48509982cee3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,20 @@
# Contributor: Excitable Snowball <excitablesnowball@gmail.com>
pkgname=python-bokeh
-pkgver=3.1.0
+pkgver=3.1.1
pkgrel=1
pkgdesc='Interactive Web Plotting for Python'
arch=('any')
url='http://bokeh.pydata.org/'
license=('BSD')
-source=("https://pypi.io/packages/source/b/bokeh/bokeh-${pkgver}.tar.gz")
-sha256sums=('9047dfe50a671b5e19ca588fd90a8e6bff197114a5dbd6a59cc2678942c27887')
+source=(
+ "https://pypi.io/packages/source/b/bokeh/bokeh-$pkgver.tar.gz"
+ 'patch'
+)
+sha256sums=(
+ 'ba0fc6bae4352d307541293256dee930a42d0acf92e760c72dc0e7397c3a28e9'
+ 'cb7cf3d3189282521206a04ad32f1cbb2667a408426ece88b4f3d26bb873e9b9'
+)
depends=('python-jinja'
'python-contourpy'
'python-numpy'
@@ -28,12 +34,16 @@ optdepends=('python-selenium: svg export'
'python-sphinx: support sphinx documentation')
makedepends=('python-build' 'python-installer')
+prepare() {
+ patch -d "$srcdir/bokeh-$pkgver" -p1 < ./patch # workaround for https://github.com/bokeh/bokeh/issues/13122
+}
+
build() {
- cd "${srcdir}"/bokeh-$pkgver
+ cd "$srcdir/bokeh-$pkgver"
python -m build --wheel
}
package() {
- cd "${srcdir}"/bokeh-$pkgver
- python -m installer "--destdir=${pkgdir}" ./dist/*.whl
+ cd "$srcdir/bokeh-$pkgver"
+ python -m installer "--destdir=$pkgdir" ./dist/*.whl
}
diff --git a/patch b/patch
new file mode 100644
index 000000000000..79d14e0ee0ae
--- /dev/null
+++ b/patch
@@ -0,0 +1,11 @@
+--- ./setup.py 2023-05-10 23:29:34.694515891 +0200
++++ ./setup.py.new 2023-05-10 23:30:12.840773479 +0200
+@@ -156,7 +156,7 @@
+
+ class Build(build): # type: ignore
+ def run(self) -> None:
+- check_tags()
++ # check_tags()
+ build_or_install_bokehjs(self.distribution.packages)
+ super().run()
+