summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-04-23 18:30:16 +0100
committerScore_Under2023-04-23 18:30:34 +0100
commitbad35abbfa9e95cd9c31aabab3fa595d857616db (patch)
tree7aa2bb0e9ab65e328e258cd32cf92b37dfc1ec41
parentca2843a6ed0485154003bb2c09fabc8ea2ea10f8 (diff)
downloadaur-bad35abbfa9e95cd9c31aabab3fa595d857616db.tar.gz
Update dependency lists, fix some namcap warnings
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
-rw-r--r--hydrus.install12
3 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68ce21fc250c..b4cb55112ae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
pkgver = 524
- pkgrel = 1
+ pkgrel = 2
url = http://hydrusnetwork.github.io/hydrus/
- install = hydrus.install
arch = any
- license = WTFPL
+ license = custom
makedepends = git
makedepends = mkdocs>=1.3.0
makedepends = mkdocs-material
@@ -26,15 +25,23 @@ pkgbase = hydrus
depends = python-qtpy
depends = emoji-font
depends = python-mpv
+ depends = python-lxml
+ depends = python-urllib3
+ depends = python-typing_extensions
depends = python-service-identity
- depends = fmt
depends = pyside6
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
+ optdepends = python-cbor2: cbor support in client-server communication
+ optdepends = python-chardet: detect text encoding more accurately
optdepends = python-cloudscraper: bypass cloudflare "checking your browser" challenges
+ optdepends = python-dateutil: improved fuzzy date search
+ optdepends = python-pympler: debug menus to profile memory usage
optdepends = python-pyqt6-charts: display bandwidth usage charts
+ optdepends = python-cryptography: to generate certificates for accessing client API and server via HTTPS
optdepends = python-pyopenssl: to generate certificates for accessing client API and server via HTTPS
+ optdepends = swftools: to display SWF thumbnails
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 88c6bcbdfc93..08a0b048316c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,33 @@ DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
_pkgname=hydrus
pkgver=524
-pkgrel=1
+pkgrel=2
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
-license=(WTFPL)
-install=hydrus.install
+license=(custom)
conflicts=(hydrus-docs hydrus-sources)
url=http://hydrusnetwork.github.io/hydrus/
depends=(python python-opencv python-beautifulsoup4 python-yaml
'python-lz4>=0.10.1' python-numpy python-twisted python-pillow
python-pysocks python-psutil python-send2trash python-html5lib
python-requests python-qtpy emoji-font python-mpv
- python-service-identity fmt pyside6)
+ python-lxml python-urllib3 python-typing_extensions
+ python-service-identity # required by twisted for https hostname verification
+ pyside6)
makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
+ 'python-cbor2: cbor support in client-server communication'
+ 'python-chardet: detect text encoding more accurately'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
+ 'python-dateutil: improved fuzzy date search'
+ 'python-pympler: debug menus to profile memory usage'
'python-pyqt6-charts: display bandwidth usage charts'
+ 'python-cryptography: to generate certificates for accessing client API and server via HTTPS'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS'
+ # 'python-pyparsing: currently unused'
+ # 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=43ae2c2593c8e900b40460191b8379229578f52c"
paths-in-opt.patch
diff --git a/hydrus.install b/hydrus.install
deleted file mode 100644
index 27c282a04440..000000000000
--- a/hydrus.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- # Ignore failures because it's only an opt dep
- update-desktop-database -q 2>/dev/null || :
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}