summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Biereigel2020-01-30 23:39:36 +0100
committerStefan Biereigel2020-01-30 23:39:36 +0100
commitbc620cb2832f94693e91c8aeab27e4770f1b12c0 (patch)
treef80f7f7ae320317f90e99a85f7b560a049f4ec47
parente5b742a6ffdf08317a1c970f325aaaa959f65e03 (diff)
downloadaur-bc620cb2832f94693e91c8aeab27e4770f1b12c0.tar.gz
sanitize prefix and destination directories
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e75ade57b234..eace4f33a146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ build(){
make config-gcc
echo "ENABLE_LIBYOSYS=1" >> Makefile.conf
echo "ENABLE_PYOSYS=1" >> Makefile.conf
- make
+ make PREFIX="/usr"
}
pkgver() {
@@ -38,7 +38,7 @@ pkgver() {
package() {
cd ${srcdir}/yosys
- make PREFIX=$pkgdir/usr/ PYTHON_PREFIX=$pkgdir/usr/ install
+ make PREFIX="/usr" PYTHON_PREFIX="$pkgdir/usr" DESTDIR="$pkgdir" install
install -D -m 644 \
"${srcdir}/LICENSE" \