summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSameer Puri2024-03-01 09:54:17 -0800
committerSameer Puri2024-03-01 09:54:17 -0800
commitbd32de6572c79761bcab964101062b879830671e (patch)
tree0560280ec474e91f6bd9eb3c0821a9145d85d1ce
parentbd0eee648faf5c26af0729a956ef5d989a4846b8 (diff)
downloadaur-bd32de6572c79761bcab964101062b879830671e.tar.gz
Update to v9.8
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--da02dfeac7f008cb7b30a5487add19401bd94b9e.patch56
3 files changed, 71 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee633aac2f82..a83138d5e312 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-or-tools
pkgdesc = Google's Operations Research tools
- pkgver = 9.7
+ pkgver = 9.8
pkgrel = 1
url = https://github.com/google/or-tools
arch = x86_64
@@ -26,7 +26,9 @@ pkgbase = python-or-tools
optdepends = python-pandas: used by some examples
optdepends = python-matplotlib: used by some examples
options = !emptydirs
- source = https://github.com/google/or-tools/archive/v9.7.tar.gz
- b2sums = ae4fa89665639894ae6feab9cb711fc493bbccecc4aa3f3cca290e28e1e77d043dbb7270567738ea6655c0daf2e8104ad08a96d2ef03959eb16eee71551eb987
+ source = https://github.com/google/or-tools/archive/v9.8.tar.gz
+ source = da02dfeac7f008cb7b30a5487add19401bd94b9e.patch
+ b2sums = 03f94d016eb9d89227c98a70cf81af2d018fbadf5debe5dae3767d5ced3f772ecfcd8e00fcf2d4df32086e369d0c5f42700b854f4efb8ea3700b86774680b672
+ b2sums = SKIP
pkgname = python-or-tools
diff --git a/PKGBUILD b/PKGBUILD
index 3e544455064f..c01257116769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sameer Puri <aur@purisa.me>
pkgname=python-or-tools
-pkgver=9.7
+pkgver=9.8
pkgrel=1
pkgdesc="Google's Operations Research tools"
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
@@ -10,17 +10,21 @@ depends=('python>=3.6' 'swig' 'python-protobuf>=3.19.4' 'absl-py' 'python-numpy>
makedepends=('cmake' 'wget' 'lsb-release' 'automake' 'python-wheel' 'python-pip' 'git' 'python-mypy-protobuf' 'python-virtualenv')
optdepends=('cplex: CPLEX solver support' 'python-pandas: used by some examples' 'python-matplotlib: used by some examples')
options=(!emptydirs)
-source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-b2sums=('ae4fa89665639894ae6feab9cb711fc493bbccecc4aa3f3cca290e28e1e77d043dbb7270567738ea6655c0daf2e8104ad08a96d2ef03959eb16eee71551eb987')
+source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz" "da02dfeac7f008cb7b30a5487add19401bd94b9e.patch")
+b2sums=('03f94d016eb9d89227c98a70cf81af2d018fbadf5debe5dae3767d5ced3f772ecfcd8e00fcf2d4df32086e369d0c5f42700b854f4efb8ea3700b86774680b672' 'SKIP')
+
+prepare() {
+ patch --directory="${srcdir}/or-tools-${pkgver}" --forward --strip=1 --input="${srcdir}/da02dfeac7f008cb7b30a5487add19401bd94b9e.patch"
+}
build() {
cd "${srcdir}/or-tools-${pkgver}"
if [ `pacman -Qi cplex &>/dev/null` ]; then
- cmake -S. -Bbuild -DBUILD_PYTHON:BOOL=ON -DUSE_CPLEX:BOOL=ON -DCPLEX_ROOT=/usr/lib/cplex
+ cmake -S. -Bbuild -DBUILD_PYTHON:BOOL=ON -DBUILD_CXX_SAMPLES=OFF -DBUILD_CXX_EXAMPLES=OFF -DUSE_CPLEX:BOOL=ON -DCPLEX_ROOT=/usr/lib/cplex
else
- cmake -S. -Bbuild -DBUILD_PYTHON:BOOL=ON
+ cmake -S. -Bbuild -DBUILD_PYTHON:BOOL=ON -DBUILD_CXX_SAMPLES=OFF -DBUILD_CXX_EXAMPLES=OFF
fi
- cmake --build build -j
+ cmake --build build -j --config Release --target all
}
package() {
diff --git a/da02dfeac7f008cb7b30a5487add19401bd94b9e.patch b/da02dfeac7f008cb7b30a5487add19401bd94b9e.patch
new file mode 100644
index 000000000000..b8381b194753
--- /dev/null
+++ b/da02dfeac7f008cb7b30a5487add19401bd94b9e.patch
@@ -0,0 +1,56 @@
+From da02dfeac7f008cb7b30a5487add19401bd94b9e Mon Sep 17 00:00:00 2001
+From: Corentin Le Molgat <corentinl@google.com>
+Date: Tue, 16 Jan 2024 15:09:40 +0100
+Subject: [PATCH] Fix pybind11_* commit sha1sum (Fix #4027)
+
+---
+ WORKSPACE | 6 ++----
+ cmake/dependencies/CMakeLists.txt | 4 ++--
+ 2 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/WORKSPACE b/WORKSPACE
+index 86377227f8..e361770963 100644
+--- a/WORKSPACE
++++ b/WORKSPACE
+@@ -219,7 +219,7 @@ install_notebook_deps()
+
+ git_repository(
+ name = "pybind11_bazel",
+- commit = "fc56ce8a8b51e3dd941139d329b63ccfea1d304b",
++ commit = "23926b00e2b2eb2fc46b17e587cf0c0cfd2f2c4b", # 2023/11/29
+ patches = ["//patches:pybind11_bazel.patch"],
+ patch_args = ["-p1"],
+ remote = "https://github.com/pybind/pybind11_bazel.git",
+@@ -234,9 +234,7 @@ new_git_repository(
+
+ new_git_repository(
+ name = "pybind11_protobuf",
+- #build_file = "@pybind11_bazel//:pybind11.BUILD",
+- #tag = "v2.10.3",
+- commit = "5baa2dc9d93e3b608cde86dfa4b8c63aeab4ac78",
++ commit = "b713501f1da56d9b76c42f89efd00b97c26c9eac", # 2023/11/29
+ remote = "https://github.com/pybind/pybind11_protobuf.git",
+ )
+
+diff --git a/cmake/dependencies/CMakeLists.txt b/cmake/dependencies/CMakeLists.txt
+index af3a28c113..f6ec06b2d0 100644
+--- a/cmake/dependencies/CMakeLists.txt
++++ b/cmake/dependencies/CMakeLists.txt
+@@ -164,7 +164,7 @@ if(BUILD_PYTHON AND BUILD_pybind11)
+ FetchContent_Declare(
+ pybind11
+ GIT_REPOSITORY "https://github.com/pybind/pybind11.git"
+- GIT_TAG "v2.10.3"
++ GIT_TAG "v2.11.1"
+ PATCH_COMMAND git apply --ignore-whitespace "${CMAKE_CURRENT_LIST_DIR}/../../patches/pybind11.patch"
+ )
+ FetchContent_MakeAvailable(pybind11)
+@@ -178,7 +178,7 @@ if(BUILD_PYTHON AND BUILD_pybind11_protobuf)
+ FetchContent_Declare(
+ pybind11_protobuf
+ GIT_REPOSITORY "https://github.com/pybind/pybind11_protobuf.git"
+- GIT_TAG "main"
++ GIT_TAG "b713501f1da56d9b76c42f89efd00b97c26c9eac" # 2023/11/29
+ PATCH_COMMAND git apply --ignore-whitespace "${CMAKE_CURRENT_LIST_DIR}/../../patches/pybind11_protobuf.patch"
+ )
+ FetchContent_MakeAvailable(pybind11_protobuf)