summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor2022-08-01 16:06:16 +0200
committerVictor2022-08-01 16:06:16 +0200
commitbd9d99ebf35b4299508d12c0d919b30e53dc0cea (patch)
treefa703c462dfbecedea2ce61b2e05abecece78ee3
parentd0b66c3a6c6de7b66d9d7ecf6941ff1c59f67440 (diff)
downloadaur-bd9d99ebf35b4299508d12c0d919b30e53dc0cea.tar.gz
Update to 1.17.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c577316656d1..e6cb8251b757 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thrust
pkgdesc = A C++ parallel programming library which resembles the C++ Standard Library
- pkgver = 1.16.0
+ pkgver = 1.17.0
pkgrel = 1
url = https://github.com/thrust/thrust
arch = any
@@ -8,9 +8,9 @@ pkgbase = thrust
optdepends = cuda: for CUDA backend
optdepends = openmp: for OMP backend
optdepends = intel-tbb: for TBB backend
- source = thrust-1.16.0.tar.gz::https://github.com/thrust/thrust/archive/1.16.0.tar.gz
- source = cub-1.16.0.tar.gz::https://github.com/thrust/cub/archive/1.16.0.tar.gz
- sha256sums = 93b9553e3ee544e05395022bea67e6d600f8f3eb680950ec7cf73c0f55162487
- sha256sums = 271dc42d0a7ab3bd311eefa4ba8fd19f99ec093cf5e9053426f358914c8983d6
+ source = thrust-1.17.0.tar.gz::https://github.com/thrust/thrust/archive/1.17.0.tar.gz
+ source = cub-1.17.0.tar.gz::https://github.com/thrust/cub/archive/1.17.0.tar.gz
+ sha256sums = b02aca5d2325e9128ed9d46785b8e72366f758b873b95001f905f22afcf31bbf
+ sha256sums = 16fd4860ae3196bc3eb08bf5754fa2a9697951ddae36dc9721e6614388893618
pkgname = thrust
diff --git a/PKGBUILD b/PKGBUILD
index 49b9df704e3d..d8c3004be75b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Xiang Gao <qasdfgtyuiop@gmail.com>
pkgname=thrust
-pkgver=1.16.0
+pkgver=1.17.0
pkgrel=1
pkgdesc='A C++ parallel programming library which resembles the C++ Standard Library'
arch=('any')
@@ -17,8 +17,8 @@ optdepends=(
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/thrust/${pkgname}/archive/${pkgver}.tar.gz"
"cub-${pkgver}.tar.gz::https://github.com/thrust/cub/archive/${pkgver}.tar.gz")
-sha256sums=('93b9553e3ee544e05395022bea67e6d600f8f3eb680950ec7cf73c0f55162487'
- '271dc42d0a7ab3bd311eefa4ba8fd19f99ec093cf5e9053426f358914c8983d6')
+sha256sums=('b02aca5d2325e9128ed9d46785b8e72366f758b873b95001f905f22afcf31bbf'
+ '16fd4860ae3196bc3eb08bf5754fa2a9697951ddae36dc9721e6614388893618')
package() {
install -dm 755 "${pkgdir}/opt/${pkgname}"