summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Kohnert2023-04-27 21:44:20 +0200
committerJan Kohnert2023-04-27 21:44:20 +0200
commitbdd156360eb124dfa264c2b0ccabf62b8d45751f (patch)
treec516d6ad2794261f18fa135336c824bd8e7e09db
parent845b16d5ac7a6f35455a1cdaf4001f245f247b4e (diff)
downloadaur-bdd156360eb124dfa264c2b0ccabf62b8d45751f.tar.gz
Resolve "Version bump 1.0.2"
-rw-r--r--.SRCINFO29
-rw-r--r--Dockerfile.build_and_test2
-rw-r--r--PKGBUILD39
-rw-r--r--gdl_pr_1337.patch156
4 files changed, 43 insertions, 183 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdbe3a678136..85e9490c0cc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,45 @@
pkgbase = gnudatalanguage
pkgdesc = An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)
- pkgver = 1.0.1
- pkgrel = 5
+ pkgver = 1.0.2
+ pkgrel = 1
url = https://gnudatalanguage.github.io/
arch = i686
arch = x86_64
license = GPL
checkdepends = openssh
makedepends = cmake
+ makedepends = eigen
+ makedepends = python-numpy
depends = eccodes
- depends = eigen
+ depends = expat
depends = fftw
+ depends = gcc-libs
+ depends = glibc
depends = glpk
depends = graphicsmagick
depends = gsl
depends = hdf4
+ depends = hdf5
depends = libgeotiff
+ depends = libpng
+ depends = libtiff
+ depends = libtirpc
+ depends = libx11
+ depends = netcdf
+ depends = openmpi
depends = plplot
- depends = python-numpy
+ depends = proj
+ depends = python
+ depends = readline
depends = shapelib
depends = udunits
depends = wxgtk3
+ depends = wxwidgets-common
+ depends = zlib
optdepends = cuda
- source = gnudatalanguage-1.0.1.tar.gz::https://github.com/gnudatalanguage/gdl/archive/v1.0.1.tar.gz
+ source = gnudatalanguage-1.0.2.tar.gz::https://github.com/gnudatalanguage/gdl/archive/v1.0.2.tar.gz
source = gdl.profile
- source = gdl_pr_1337.patch
- sha512sums = 9d15f114d26d03c34dce6177a5d5115e81c128ec21752c01d171f8427e6cb21b9d0b69a44e29891b5e8fc2bd4d0b89d1a8dcd189f362a13c6e59182528b5842d
+ sha512sums = 19869b68343ae8532ec9e27c402f69986d8269cc1f4c6af55402bef74f6dbee88c82b4c67db093b3be63377afb9a9a870f7baf484c8278d54ee5a7b5a428206a
sha512sums = b3a3589d2ce8eb5d49c902aa9bc43df0a0fcc369d17deb060026d34fa821881a212ce6aa02edc7ea6c0476b2faacc7455e467af7b5baf672e2653b71b162190f
- sha512sums = 2d000c4c619bf59ad21244b758250e4c458ca0d4309ea0a89bd3e79ced0335e15984262ac8577baabcaaf1e4e50dc3ea7450f3f15bc71576e497fa189a4d484a
pkgname = gnudatalanguage
diff --git a/Dockerfile.build_and_test b/Dockerfile.build_and_test
index f49a6900a5f4..cd682be85aca 100644
--- a/Dockerfile.build_and_test
+++ b/Dockerfile.build_and_test
@@ -3,7 +3,7 @@ ARG REGISTRY
FROM "$REGISTRY/common/gitlab-helper/archlinux-yay:master"
RUN (\
- yay -Syuq --noconfirm --needed python-numpy eigen plplot gsl hdf4 wxgtk3 fftw pslib eccodes udunits graphicsmagick libgeotiff glpk shapelib openssh xorg-server-xvfb \
+ yay -Syuq --noconfirm --needed python-numpy eigen plplot gsl hdf4 hdf5 wxgtk3 fftw pslib eccodes udunits graphicsmagick libgeotiff glpk shapelib openssh xorg-server-xvfb \
&& yes | yay -Scc --noconfirm \
&& rm -rf ~/.cache/yay \
&& sudo rm -rf /var/cache/pacman/pkg/* \
diff --git a/PKGBUILD b/PKGBUILD
index 4a8dea846c1a..010380c22231 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,23 @@
# Contributor: Orlando Garcia Feal <rodland at gmail dot com>
pkgname=gnudatalanguage
-pkgver=1.0.1
-pkgrel=5
+pkgver=1.0.2
+pkgrel=1
pkgdesc="An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)"
arch=("i686" "x86_64")
url="https://gnudatalanguage.github.io/"
license=("GPL")
-depends=("eccodes" "eigen" "fftw" "glpk" "graphicsmagick" "gsl" "hdf4"
- "libgeotiff" "plplot" "python-numpy" "shapelib" "udunits" "wxgtk3")
-makedepends=("cmake")
+depends=("eccodes" "expat" "fftw" "gcc-libs" "glibc" "glpk" "graphicsmagick"
+ "gsl" "hdf4" "hdf5" "libgeotiff" "libpng" "libtiff" "libtirpc" "libx11"
+ "netcdf" "openmpi" "plplot" "proj" "python" "readline" "shapelib"
+ "udunits" "wxgtk3" "wxwidgets-common" "zlib")
+makedepends=("cmake" "eigen" "python-numpy")
checkdepends=("openssh")
optdepends=("cuda")
source=("$pkgname-$pkgver.tar.gz::https://github.com/gnudatalanguage/gdl/archive/v${pkgver}.tar.gz"
- "gdl.profile"
- "gdl_pr_1337.patch")
-sha512sums=("9d15f114d26d03c34dce6177a5d5115e81c128ec21752c01d171f8427e6cb21b9d0b69a44e29891b5e8fc2bd4d0b89d1a8dcd189f362a13c6e59182528b5842d"
- "b3a3589d2ce8eb5d49c902aa9bc43df0a0fcc369d17deb060026d34fa821881a212ce6aa02edc7ea6c0476b2faacc7455e467af7b5baf672e2653b71b162190f"
- "2d000c4c619bf59ad21244b758250e4c458ca0d4309ea0a89bd3e79ced0335e15984262ac8577baabcaaf1e4e50dc3ea7450f3f15bc71576e497fa189a4d484a")
-
-prepare() {
- cd "${srcdir}/gdl-${pkgver}"
- patch -p1 -i "${srcdir}/gdl_pr_1337.patch"
-}
+ "gdl.profile")
+sha512sums=("19869b68343ae8532ec9e27c402f69986d8269cc1f4c6af55402bef74f6dbee88c82b4c67db093b3be63377afb9a9a870f7baf484c8278d54ee5a7b5a428206a"
+ "b3a3589d2ce8eb5d49c902aa9bc43df0a0fcc369d17deb060026d34fa821881a212ce6aa02edc7ea6c0476b2faacc7455e467af7b5baf672e2653b71b162190f")
build() {
cd "${srcdir}/gdl-${pkgver}"
@@ -36,15 +31,23 @@ build() {
cd build
cmake -Wno-dev -DCMAKE_INSTALL_PREFIX=/usr -DEIGEN3=ON -DFFTW=ON -DGLPK=ON \
-DGRAPHICSMAGICK=ON -DGRIB=ON -DHDF5=ON -DHDF=ON -DHDFDIR=/opt/hdf4 \
- -DLIBPROJ=ON -DMAGICK=OFF -DMPI=ON -DNETCDF=ON -DPYTHON_MODULE=OFF \
- -DREADLINE=ON -DSHAPELIB=ON -DUDUNITS2=ON -DPYTHON=ON -DPYTHONVERSION=3 ..
+ -DLIBPROJ=ON -DMAGICK=OFF -DMPI=ON -DNETCDF=ON -DPYTHON=ON \
+ -DPYTHONVERSION=3 -DPYTHON_MODULE=OFF -DQHULL=OFF -DREADLINE=ON \
+ -DSHAPELIB=ON -DUDUNITS2=ON ..
make
}
check() {
cd "${srcdir}/gdl-${pkgver}/build"
- ctest --output-on-failure
+
+ # we need *..driver_info files, those are installed but not in
+ while IFS= read -r -d '' file
+ do
+ base=$(basename "${file}" .so)
+ cp ../src/plplotdriver/"${base}".driver_info src/plplotdriver/"${base}".driver_info
+ done < <(find src/plplotdriver -name \*.so -print0)
+ PLPLOT_DRV_DIR="src/plplotdriver/" ctest --output-on-failure
}
package() {
diff --git a/gdl_pr_1337.patch b/gdl_pr_1337.patch
deleted file mode 100644
index f46cb0ca1b00..000000000000
--- a/gdl_pr_1337.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-commit 2f4f47ea07a3a13ae7793d8ab9c21c97bc77567a
-Author: Jan Kohnert <jan@jan-kohnert.de>
-Date: Thu May 26 12:32:01 2022 +0200
-
- Replaced deprecated std::unary_function and std::binary_function by C++11 std::function
-
-diff --git a/src/antlr/CharScanner.hpp b/src/antlr/CharScanner.hpp
-index c123cb17..c5e0604d 100644
---- a/src/antlr/CharScanner.hpp
-+++ b/src/antlr/CharScanner.hpp
-@@ -31,6 +31,9 @@
- # include <stdio.h>
- #endif
-
-+// std::function needs this one
-+#include <functional>
-+
- #include <antlr/TokenStream.hpp>
- #include <antlr/RecognitionException.hpp>
- #include <antlr/SemanticException.hpp>
-@@ -71,7 +74,7 @@ ANTLR_C_USING(strcasecmp)
-
- /** Functor for the literals map
- */
--class ANTLR_API CharScannerLiteralsLess : public ANTLR_USE_NAMESPACE(std)binary_function<ANTLR_USE_NAMESPACE(std)string,ANTLR_USE_NAMESPACE(std)string,bool> {
-+class ANTLR_API CharScannerLiteralsLess : public ANTLR_USE_NAMESPACE(std)function<bool(ANTLR_USE_NAMESPACE(std)string,ANTLR_USE_NAMESPACE(std)string)> {
- private:
- const CharScanner* scanner;
- public:
-diff --git a/src/dcommon.hpp b/src/dcommon.hpp
-index 35dc3c8c..d7965974 100644
---- a/src/dcommon.hpp
-+++ b/src/dcommon.hpp
-@@ -65,7 +65,7 @@ public:
- DCommon* getCommon(void) { return this; };
- };
-
--class DCommon_eq: public std::unary_function<DCommon,bool>
-+class DCommon_eq: public std::function<bool(DCommon)>
- {
- std::string name;
- public:
-@@ -102,7 +102,7 @@ public:
- typedef std::vector<DCommonBase*> CommonBaseListT;
- typedef std::vector<DCommon*> CommonListT;
-
--class DCommon_contains_var: public std::unary_function<DCommonBase,bool>
-+class DCommon_contains_var: public std::function<bool(DCommonBase*)>
- {
- std::string name;
- public:
-diff --git a/src/dcompiler.hpp b/src/dcompiler.hpp
-index 805e7fb6..1947bfb0 100644
---- a/src/dcompiler.hpp
-+++ b/src/dcompiler.hpp
-@@ -94,7 +94,7 @@ public:
- EnvBaseT* GetEnv() const { return env;}
- void SetEnv( EnvBaseT* e) { env = e;}
- // for sorting lists by name
-- struct CompLibFunName: public std::binary_function< DLibFun*, DLibFun*, bool>
-+ struct CompLibFunName: public std::function<bool(DLibFun*, DLibFun*)>
- {
- bool operator() ( DLibFun* f1, DLibFun* f2) const
- { return f1->ObjectName() < f2->ObjectName();}
-diff --git a/src/dpro.hpp b/src/dpro.hpp
-index 5df241a3..e234b16e 100644
---- a/src/dpro.hpp
-+++ b/src/dpro.hpp
-@@ -36,7 +36,7 @@
- extern bool posixpaths;
- }
- #endif
--template<typename T> class Is_eq: public std::unary_function<T,bool>
-+template<typename T> class Is_eq: public std::function<bool(T)>
- {
- std::string name;
- public:
-@@ -208,7 +208,7 @@ public:
-
- // for sorting lists by name. Not used (lists too short to make a time gain. Long lists would, if existing,
- // benefit from sorting by hash number in a std::map instead of a std::list.
-- struct CompLibFunName: public std::binary_function< DLib*, DLib*, bool>
-+ struct CompLibFunName: public std::function<bool(DLib*, DLib*)>
- {
- bool operator() ( DLib* f1, DLib* f2) const
- { return f1->ObjectName() < f2->ObjectName();}
-diff --git a/src/dstructdesc.hpp b/src/dstructdesc.hpp
-index b09a371c..659cab15 100644
---- a/src/dstructdesc.hpp
-+++ b/src/dstructdesc.hpp
-@@ -362,7 +362,7 @@ public:
- };
-
-
--class DStruct_eq: public std::unary_function<DStructDesc,bool>
-+class DStruct_eq: public std::function<bool(DStructDesc)>
- {
- std::string name;
-
-diff --git a/src/dvar.hpp b/src/dvar.hpp
-index e34ce70e..37b33cc5 100644
---- a/src/dvar.hpp
-+++ b/src/dvar.hpp
-@@ -57,7 +57,7 @@ public:
-
- typedef std::vector<DVar*> VarListT;
-
--class DVar_eq: public std::unary_function<DVar,bool>
-+class DVar_eq: public std::function<bool(DVar)>
- {
- std::string name;
- BaseGDL* pp;
-diff --git a/src/gdlhelp.cpp b/src/gdlhelp.cpp
-index 2216bbb2..837dbd3b 100644
---- a/src/gdlhelp.cpp
-+++ b/src/gdlhelp.cpp
-@@ -126,7 +126,7 @@ extern "C" {
-
-
- // for sorting compiled pro/fun lists by name
--struct CompFunName: public std::binary_function< DFun*, DFun*, bool>
-+struct CompFunName: public std::function<bool(DFun*, DFun*)>
- {
- bool operator() ( DFun* f1, DFun* f2) const
- {
-@@ -134,7 +134,7 @@ struct CompFunName: public std::binary_function< DFun*, DFun*, bool>
- }
- };
-
--struct CompProName: public std::binary_function< DPro*, DPro*, bool>
-+struct CompProName: public std::function<bool(DPro*, DPro*)>
- {
- bool operator() ( DPro* f1, DPro* f2) const
- {
-diff --git a/src/str.hpp b/src/str.hpp
-index e88dff88..2459157d 100644
---- a/src/str.hpp
-+++ b/src/str.hpp
-@@ -88,7 +88,7 @@ void StrLowCaseInplace(std::string&);
- std::string StrCompress(const std::string&,bool removeAll);
- void StrPut(std::string& s1, const std::string& s2, DLong pos);
-
--class String_abbref_eq: public std::unary_function< std::string, bool>
-+class String_abbref_eq: public std::function<bool(std::string)>
- {
- std::string s;
- public:
-@@ -100,7 +100,7 @@ public:
- }
- };
-
--class String_eq: public std::unary_function< std::string, bool>
-+class String_eq: public std::function<bool(std::string)>
- {
- std::string s;
- public: