summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-12 14:34:18 -0800
committerxiota2023-12-12 14:55:01 -0800
commitbf5cc1dc6241ffc6ec12b41c7927c8e3ecd51cb6 (patch)
tree6255826824f3aeb4005c31f9625190a6b1049cb9
parent8daa1f3b57723f018d6be838245917a9ea6e336f (diff)
downloadaur-bf5cc1dc6241ffc6ec12b41c7927c8e3ecd51cb6.tar.gz
r26071.d590cfb9d
add udev rule for hidraw access to nintendo controllers add env variable to build with -march=x86-64-v3 update license
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD24
2 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c630c1f8718f..dc6cc465ceec 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch
- pkgver = r26003.e9a43bae6
+ pkgver = r26071.d590cfb9d
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL-3.0-only
makedepends = boost
makedepends = catch2
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 42d4761b182c..7e94d8edabd4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,29 @@
# Contributor: Brendan Szymanski <hello@bscubed.dev>
# options
+: ${_avx_build:=false}
+
: ${_pkgtype:=git}
+
+if [[ "${_avx_build::1}" == "t" ]] ; then
+ if [ "${_pkgtype: -4}" == "-git" ] ; then
+ _pkgtype="${_pkgtype%-*}-avx-${_pkgtype##*-}"
+ elif [ "${_pkgtype::1}" == "g" ] ; then
+ _pkgtype="avx-$_pkgtype"
+ else
+ _pkgtype+="-avx"
+ fi
+fi
+
# basic info
_pkgname="yuzu"
pkgname="$_pkgname${_pkgtype:+-$_pkgtype}"
-pkgver=r26003.e9a43bae6
+pkgver=r26071.d590cfb9d
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
url="https://github.com/yuzu-emu/yuzu"
-license=('GPL2')
+license=('GPL-3.0-only')
arch=('i686' 'x86_64')
# main package
@@ -251,6 +264,11 @@ prepare() {
}
build() {
+ if [[ "${_avx_build::1}" == "t" ]] ; then
+ export CFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
+ export CXXFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
+ fi
+
local _cmake_options=(
-S "$_pkgsrc"
-B build
@@ -291,6 +309,8 @@ build() {
package() {
DESTDIR="${pkgdir:?}" cmake --install build
+
+ install -Dm644 "$_pkgsrc/dist/72-yuzu-input.rules" -t "$pkgdir/usr/lib/udev/rules.d/"
}
# execut