summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P.2023-12-26 17:08:14 -0500
committerLeo P.2023-12-26 17:08:14 -0500
commitbf7a21bf545404d29daddfdfd5d44f0d8668ebd0 (patch)
tree7ee39b4c2b9189d05d4ddf4bb2b0268cc3db3230
parent9f516b21bc00a6f84448ec32174a921bbc23c169 (diff)
downloadaur-bf7a21bf545404d29daddfdfd5d44f0d8668ebd0.tar.gz
bump
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
-rw-r--r--ifdtools-nowerror.patch12
4 files changed, 45 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 953c0a9d31f2..0a46f7ce9bea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = coreboot-utils
pkgdesc = Tools and utilities to work with coreboot firmware
- pkgver = 4.20.1
+ pkgver = 4.22.01
pkgrel = 1
url = https://www.coreboot.org/
arch = x86_64
@@ -8,11 +8,15 @@ pkgbase = coreboot-utils
makedepends = go
depends = glibc
depends = pciutils
+ depends = zlib
optdepends = python: me_cleaner support
- source = https://coreboot.org/releases/coreboot-4.20.1.tar.xz
- source = https://coreboot.org/releases/coreboot-4.20.1.tar.xz.sig
+ provides = ectool
+ source = https://coreboot.org/releases/coreboot-4.22.01.tar.xz
+ source = https://coreboot.org/releases/coreboot-4.22.01.tar.xz.sig
+ source = ifdtools-nowerror.patch
validpgpkeys = 574CE6F6855CFDEB7D368E9D19796C2B3E4F7DF7
- sha256sums = b41539a8c2eab2fec752157eb4acbd0e2a637a7203530c12e66b43a5c3c3a931
+ sha256sums = 3d1a36dfb2a654133c7f36cf4da436f0d79f535644069adfe7cdcad962532c3f
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = coreboot-utils
diff --git a/.gitignore b/.gitignore
index d778e6b9e155..72a3ed3fe6e0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-*.tar.xz
-*.tar.gz
+*.tar*
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index dd042d9c0eeb..fa5524dcf9a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,49 @@
# Maintainer:
# Contributor: slact
pkgname=coreboot-utils
-pkgver=4.20.1
+pkgver=4.22.01
pkgrel=1
pkgdesc="Tools and utilities to work with coreboot firmware"
url="https://www.coreboot.org/"
license=('GPL2')
arch=('x86_64')
-depends=('glibc' 'pciutils')
+depends=('glibc' 'pciutils' 'zlib')
optdepends=('python: me_cleaner support')
-source=("https://coreboot.org/releases/coreboot-$pkgver.tar.xz"{,.sig})
-sha256sums=('b41539a8c2eab2fec752157eb4acbd0e2a637a7203530c12e66b43a5c3c3a931'
- 'SKIP')
+source=("https://coreboot.org/releases/coreboot-$pkgver.tar.xz"{,.sig} ifdtools-nowerror.patch)
+sha256sums=('3d1a36dfb2a654133c7f36cf4da436f0d79f535644069adfe7cdcad962532c3f'
+ 'SKIP'
+ 'SKIP')
validpgpkeys=('574CE6F6855CFDEB7D368E9D19796C2B3E4F7DF7') # Martin Roth (coreboot developer) <martin@coreboot.org>
+provides=('ectool')
BUILD_AUTOPORT=y
if [ "$BUILD_AUTOPORT" == y ]; then
makedepends=("${makedepends[@]}" go)
fi
-build() {
+prepare() {
cd "coreboot-$pkgver"
+ patch -p0 < ../ifdtools-nowerror.patch
+}
- for tool in cbfstool cbmem ectool ifdtool intelmetool inteltool intelvbttool \
- nvramtool superiotool; do
- make -C "util/${tool}"
+build() {
+ cd "coreboot-$pkgver/src"
+
+ for tool in amdfwtool cbfstool cbmem ectool ifdtool intelmetool inteltool intelvbttool nvramtool superiotool; do
+ case $tool in
+ "intelmetool")
+ make -C "../util/${tool}"
+# make -C "../util/${tool}" "${tool}"
+ ;;
+ *)
+ make -C "../util/${tool}"
+ ;;
+ esac
done
if [ "$BUILD_AUTOPORT" == y ]; then
- cd util/autoport
+ cd ../util/autoport
go build
fi
}
diff --git a/ifdtools-nowerror.patch b/ifdtools-nowerror.patch
new file mode 100644
index 000000000000..074eb1c8bd35
--- /dev/null
+++ b/ifdtools-nowerror.patch
@@ -0,0 +1,12 @@
+--- util/ifdtool/Makefile.inc 2023-12-26 16:28:55.501707610 -0500
++++ util/ifdtool/Makefile.inc 2023-12-26 16:29:07.721749140 -0500
+@@ -2,7 +2,7 @@
+
+ ifdtoolobj = ifdtool.o fmap.o kv_pair.o valstr.o
+
+-IFDTOOLCFLAGS = -O2 -g -Wall -Wextra -Wmissing-prototypes -Werror
++IFDTOOLCFLAGS = -O2 -g -Wall -Wextra -Wmissing-prototypes
+ IFDTOOLCFLAGS += -I$(top)/src/commonlib/include -I$(top)/src/commonlib/bsd/include
+ IFDTOOLCFLAGS += -I$(top)/util/cbfstool/flashmap
+ IFDTOOLCFLAGS += -include $(top)/src/commonlib/bsd/include/commonlib/bsd/compiler.h
+ \ No newline at end of file