summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-10-27 16:40:54 -0700
committerxiota2023-10-27 16:41:09 -0700
commitc4f9f816c40edfef77891de4d211092baa1864a9 (patch)
tree451ff3f8923d4e63de482cb6af008e3f133d21ff
parentd715f5626fb0cafa0d1c5026a15d2a25b8d9fbbf (diff)
downloadaur-c4f9f816c40edfef77891de4d211092baa1864a9.tar.gz
2.0.0.r42: update depends, minor adjustments
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d91cefd15a49..df3279cc826e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddcutil-git
pkgdesc = Query and change Linux monitor settings using DDC/CI and USB.
- pkgver = 2.0.0.r3.g4e6f15d2
+ pkgver = 2.0.0.r42.g19baa12e
pkgrel = 1
url = https://github.com/rockowitz/ddcutil
arch = x86_64
@@ -9,14 +9,15 @@ pkgbase = ddcutil-git
makedepends = git
depends = glib2
depends = i2c-tools
+ depends = jansson
depends = kmod
depends = libdrm
depends = libusb
depends = libxrandr
- provides = libddcutil.so=5
provides = ddcutil=2.0.0
conflicts = ddcutil
- source = ddcutil::git+https://github.com/rockowitz/ddcutil
+ source = ddcutil::git+https://github.com/rockowitz/ddcutil.git
sha256sums = SKIP
pkgname = ddcutil-git
+ provides = libddcutil.so
diff --git a/PKGBUILD b/PKGBUILD
index 06867b37921c..59345fa17aa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer:
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Pagnite <tymoteuszdolega at gmail dot com>
# Contributor: Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
# Contributor: Felix Yan <felixonmars@archlinux.org>
@@ -6,7 +7,7 @@
_pkgname="ddcutil"
pkgname="$_pkgname-git"
-pkgver=2.0.0.r3.g4e6f15d2
+pkgver=2.0.0.r42.g19baa12e
pkgrel=1
pkgdesc='Query and change Linux monitor settings using DDC/CI and USB.'
url='http://ddcutil.com/'
@@ -16,6 +17,7 @@ license=('GPL2')
depends=(
'glib2'
'i2c-tools'
+ 'jansson'
'kmod'
'libdrm'
'libusb'
@@ -25,27 +27,19 @@ makedepends=(
'systemd'
)
-provides=(
- 'libddcutil.so=5'
-)
-
if [ "$_pkgname" != "$pkgname" ] ; then
url="https://github.com/rockowitz/ddcutil"
makedepends+=('git')
- provides+=("$_pkgname=${pkgver/.r*}")
+ provides+=("$_pkgname=${pkgver%%.r*}")
conflicts+=("$_pkgname")
_pkgsrc="$_pkgname"
- source=(
- "$_pkgname"::"git+$url"
- )
- sha256sums=(
- 'SKIP'
- )
+ source=("$_pkgname"::"git+$url.git")
+ sha256sums=('SKIP')
pkgver() {
cd "$_pkgsrc"
- git describe --long --tags --match 'v[0-9].[0-9].[0-9]' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
fi
@@ -61,6 +55,8 @@ build() {
}
package() {
+ provides=('libddcutil.so')
+
cd "$_pkgsrc"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir:?}" install
}